summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 08:48:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-14 08:48:16 +0100
commit97268176352f52f2ed50a716cdb1b032180a2686 (patch)
tree682532237c64b848187695be13ca93e06c633d2b /dev-python/jupyter_client
parentdev-python/hypothesis: Bump to 6.8.1 (diff)
downloadgentoo-97268176352f52f2ed50a716cdb1b032180a2686.tar.gz
gentoo-97268176352f52f2ed50a716cdb1b032180a2686.tar.bz2
gentoo-97268176352f52f2ed50a716cdb1b032180a2686.zip
dev-python/jupyter_client: Bump to 6.1.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.12.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 05523cebb23e..01d6e644887b 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-6.1.11.tar.gz 293651 BLAKE2B 73a8567927c452a6a6a591eed04d592c6bb52211214e6d27ae816a2ce07a61c3f80991a2209b42c1d679ff6d3ead564f6ac97e6500473e0e5bd86bad83db07c1 SHA512 3cd6c3d299ea7097b04ad88b08dad8c23d90c5feee18bf441434a6069151b85717c4d00d2c186c463995d26383442c4f63c86565b1606e60afb61426515f9a11
+DIST jupyter_client-6.1.12.tar.gz 301499 BLAKE2B 8041b84ad2e89413ee60d1aee2e49a67a89b5aad1c3118c8fa7d7d719c8ec2acbc72278c9aaea095cdcb89235800d09b1792b2138c09a4aad59ceaaf695af431 SHA512 f31ff1a24b264c32d35d07491785e1d77935cdb463243e90e4aadcb0a093a074cdce75f01662591766588f39b146077639ca697f71157309dc92f12ae04d5cdd
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
new file mode 100644
index 000000000000..8f92382aed2c
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ <dev-python/jedi-0.17.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest