summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-18 08:49:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-18 09:05:38 +0200
commitdcd217e469283bbd40b4cd9d3b8f65333962502e (patch)
tree9c14ea0929bee0dad1deccd37aae31a89c75bb3b /dev-python/jupyter_console
parentdev-python/jsonpointer: Remove old (diff)
downloadgentoo-dcd217e469283bbd40b4cd9d3b8f65333962502e.tar.gz
gentoo-dcd217e469283bbd40b4cd9d3b8f65333962502e.tar.bz2
gentoo-dcd217e469283bbd40b4cd9d3b8f65333962502e.zip
dev-python/jupyter_console: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_console')
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/files/jupyter_console-6.1.0-increase-test-timeout.patch15
-rw-r--r--dev-python/jupyter_console/files/jupyter_console-6.1.0-py39.patch51
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.1.0-r2.ebuild49
4 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
index 219360b6e4c8..1dcf9942d4f0 100644
--- a/dev-python/jupyter_console/Manifest
+++ b/dev-python/jupyter_console/Manifest
@@ -1,3 +1,2 @@
-DIST jupyter_console-6.1.0.tar.gz 28468 BLAKE2B 08ef158de6a0eb8fe741dac00b74e11f7e577b5097f54aa16c47ae9e39607231e19a1fcd0a96cbae41d41fad891fefdb532d0f66bc03aa66ff99a8d3ff3cb28c SHA512 abb5457a90d109457e91071cd8b592a14bec7ead75fd667d656f9180a457e39bf470877b2e17c81ff512d1cc69b62a8f700996492f6164eb05a1581db82abbf7
DIST jupyter_console-6.3.0.tar.gz 35313 BLAKE2B 980eac57de949654bf99d99eb74d8600d73d0699ab394e0ad4c5e937fdc278477442e0e95887c95f631ba1bc2b2469c36cc6e4bca8d5f11f97c4943c2f312c4f SHA512 777d9cf8b842eccea108a1857c421fec1bcdf8c226a6947d7ff4ee5d5da4bdbb50096e9e63638053d8eb200e55c093c753010ffb1460dae5579de16aad4e64a6
DIST jupyter_console-6.4.0.tar.gz 35765 BLAKE2B 48278110338184dbcae242a059c3ba7e0c642d24eaac828786ff9f3c588747f447727a8da1d366ed305eeb5d003d4fabd9b9eea063e8fd5178774108cbef77da SHA512 e2b301cfd3a56ee4cf33d5cfb297726d0f4478562167ed0f0a9320d389118fa661a85b6a5ef24db60673a76d84545bcdb9741bfdd9f8d13ccdbbc5c5e52d7227
diff --git a/dev-python/jupyter_console/files/jupyter_console-6.1.0-increase-test-timeout.patch b/dev-python/jupyter_console/files/jupyter_console-6.1.0-increase-test-timeout.patch
deleted file mode 100644
index 684ecfc0a841..000000000000
--- a/dev-python/jupyter_console/files/jupyter_console-6.1.0-increase-test-timeout.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Very slow CIs take longer on this test
-
---- a/jupyter_console/tests/test_console.py
-+++ b/jupyter_console/tests/test_console.py
-@@ -65,8 +65,8 @@
- except IOError:
- raise SkipTest("Couldn't find command %s" % cmd)
-
-- # timeout after one minute
-- t = 60
-+ # timeout after 5 minutes
-+ t = 300
- idx = p.expect(r'In \[\d+\]', timeout=t)
- return p, pexpect, t
-
diff --git a/dev-python/jupyter_console/files/jupyter_console-6.1.0-py39.patch b/dev-python/jupyter_console/files/jupyter_console-6.1.0-py39.patch
deleted file mode 100644
index 92d3532649e9..000000000000
--- a/dev-python/jupyter_console/files/jupyter_console-6.1.0-py39.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 3b648aab9ce731beab1f02d714a97905ab0e42e1 Mon Sep 17 00:00:00 2001
-From: Karthikeyan Singaravelan <tir.karthi@gmail.com>
-Date: Thu, 2 Jan 2020 18:30:41 +0530
-Subject: [PATCH] Fix deprecation warning in base64
-
----
- jupyter_console/ptshell.py | 6 +++---
- jupyter_console/tests/test_image_handler.py | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/jupyter_console/ptshell.py b/jupyter_console/ptshell.py
-index 84af32f..6a55fe1 100644
---- a/jupyter_console/ptshell.py
-+++ b/jupyter_console/ptshell.py
-@@ -818,12 +818,12 @@ def handle_image_PIL(self, data, mime):
- from PIL import Image, ImageShow
- except ImportError:
- return False
-- raw = base64.decodestring(data[mime].encode('ascii'))
-+ raw = base64.decodebytes(data[mime].encode('ascii'))
- img = Image.open(BytesIO(raw))
- return ImageShow.show(img)
-
- def handle_image_stream(self, data, mime):
-- raw = base64.decodestring(data[mime].encode('ascii'))
-+ raw = base64.decodebytes(data[mime].encode('ascii'))
- imageformat = self._imagemime[mime]
- fmt = dict(format=imageformat)
- args = [s.format(**fmt) for s in self.stream_image_handler]
-@@ -835,7 +835,7 @@ def handle_image_stream(self, data, mime):
- return (proc.returncode == 0)
-
- def handle_image_tempfile(self, data, mime):
-- raw = base64.decodestring(data[mime].encode('ascii'))
-+ raw = base64.decodebytes(data[mime].encode('ascii'))
- imageformat = self._imagemime[mime]
- filename = 'tmp.{0}'.format(imageformat)
- with NamedFileInTemporaryDirectory(filename) as f, \
-diff --git a/jupyter_console/tests/test_image_handler.py b/jupyter_console/tests/test_image_handler.py
-index 5296635..b2a5ea9 100644
---- a/jupyter_console/tests/test_image_handler.py
-+++ b/jupyter_console/tests/test_image_handler.py
-@@ -32,7 +32,7 @@ def setUp(self):
- self.shell = NonCommunicatingShell()
- self.raw = b'dummy data'
- self.mime = 'image/png'
-- self.data = {self.mime: base64.encodestring(self.raw).decode('ascii')}
-+ self.data = {self.mime: base64.encodebytes(self.raw).decode('ascii')}
-
- def test_call_pil_by_default(self):
- pil_called_with = []
diff --git a/dev-python/jupyter_console/jupyter_console-6.1.0-r2.ebuild b/dev-python/jupyter_console/jupyter_console-6.1.0-r2.ebuild
deleted file mode 100644
index bf2123863415..000000000000
--- a/dev-python/jupyter_console/jupyter_console-6.1.0-r2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- <dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]"
-# util-linux provides script(1)
-BDEPEND="
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- sys-apps/util-linux
- )"
-
-distutils_enable_sphinx docs \
- dev-python/sphinxcontrib-github-alt dev-python/sphinx_rtd_theme
-distutils_enable_tests nose
-
-PATCHES=(
- "${FILESDIR}"/${P}-py39.patch
- "${FILESDIR}"/${P}-increase-test-timeout.patch
-)
-
-python_prepare_all() {
- # use setuptools unconditionally
- sed -i -e 's:distutils\.core:setuptools:' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- script -eqc "nosetests -v" || die
-}