summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-02-20 09:25:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-21 09:12:51 +0100
commit0c142f21bca581d648b35f0d34e56eb7555db844 (patch)
tree306bef7678449e8d324ab7db137c6cfe5f05f327 /dev-python/jupyter_core
parentapp-shells/tcsh: cleanup (diff)
downloadgentoo-0c142f21bca581d648b35f0d34e56eb7555db844.tar.gz
gentoo-0c142f21bca581d648b35f0d34e56eb7555db844.tar.bz2
gentoo-0c142f21bca581d648b35f0d34e56eb7555db844.zip
dev-python/jupyter_core: Drop old
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/4042
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.2.0.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 0fe4b1d96f5e..6078e4c00a6c 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1,4 +1,3 @@
DIST jupyter_core-4.0.6.tar.gz 55060 SHA256 96a68a3b1d018ff7776270b26b7cb0cfd7a18a53ef2061421daff435707d198c SHA512 e6d7a0293ce6cdd3202b354aae62900683eb0474590980bf3d9c6f89b4b16182e7caee0e42c3feb3de5851535a01394b20725d9428eb105dbc2c34d90e0d398b WHIRLPOOL c1370d386c63665db1a47f1df0e3942c713b4f9e71ad5a2bd8c83bcf1b5dfe937fdadcd606335a989514499b9e6446d92a0bb250b9e972181b12d0d9423ee80a
DIST jupyter_core-4.1.0.tar.gz 56500 SHA256 146af0679c33c56db4b85b785f3dacd933ffaca97e7d2d56ff577a5485c2bd13 SHA512 863c4611093e914d92ac268d26e546842132d398d30f78c8440830a426da2923912b7da484ca3282a3f737300af316a305b8417cd1c35acd4a0ff93de1309d39 WHIRLPOOL 80427965a8394f1e86e0fc9a456eb3396cf37ed6e3c4362acb5998121d7b02c3242c3405871a2c25b71394716af039211a994fdbac5e833cc55c7beeb6e29d4e
-DIST jupyter_core-4.2.0.tar.gz 57722 SHA256 44ec837a53bebf4e937112d3f9ccf31fee4f8db3e406dd0dd4f0378a354bed9c SHA512 37e4ffa2ce9b3f8bdd4d1e520050e6919a8bbf1345f5684bcabeab158b4c014b1b49e7e58705cb623ed53ef63ef26b67d236fb48d285b68b76b928d516706b37 WHIRLPOOL 69372c9c545171ab34cc4d721402d4226431f8d44edbf0964022747e26a79df30542d355827fd5061fc57e0a54715984f8094df266e71185f591b247ccafa1ee
DIST jupyter_core-4.2.1.tar.gz 61794 SHA256 89c55399c8437f777197c2c82c1ff5639c7f71d4eb2f172a81afa120b68dc7b3 SHA512 775a1ddbf6f6cbd44bf924017832c4fa394c453c778639d4d58ca9a11d79574c5203858bd05683210c887ba469baae1290d1885a59833b129064a9c59345ad19 WHIRLPOOL b1797cd8884bf56f7c6d85123251572d18ee0a46bc5b3c8b6bbb97bcfa82b9f70b8b74aaba837293a11c714a5c0ecf99f0740c0d0e3d2250d4cd019533c21f00
diff --git a/dev-python/jupyter_core/jupyter_core-4.2.0.ebuild b/dev-python/jupyter_core/jupyter_core-4.2.0.ebuild
deleted file mode 100644
index 21738d9c38a6..000000000000
--- a/dev-python/jupyter_core/jupyter_core-4.2.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core common functionality of Jupyter projects"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/traitlets[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- !!<dev-python/jupyter-1.0.0-r1
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- py.test jupyter_core || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}