summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-17 09:36:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-17 10:31:06 +0200
commitea404fac822e770e5369520aad4b57147542f638 (patch)
tree097c2f23746e810adeb3119c1d2827a59cc1f391 /dev-python/jupyter_core
parentdev-python/flexmock: Bump to 0.10.10 (diff)
downloadgentoo-ea404fac822e770e5369520aad4b57147542f638.tar.gz
gentoo-ea404fac822e770e5369520aad4b57147542f638.tar.bz2
gentoo-ea404fac822e770e5369520aad4b57147542f638.zip
dev-python/jupyter_core: Bump to 4.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.8.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 652b0a40d7e9..3289221e28d1 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.7.1.tar.gz 68886 BLAKE2B aa89351845c669474c03a307934a5d84b6357679bc99f2fc7da4f93ff347766d52ce3551780803b73941d6457f7004306e795398fd390c81e9180193a2119225 SHA512 bc190abd000566dbd097dcb14acf1926c92bb265f2cfbbd14dac6a9cf7d6a02f924ba89fa957ca30c2af57433e9187e288bb8e80d039a3d3a583c6e488a9c80e
+DIST jupyter_core-4.8.1.tar.gz 73579 BLAKE2B d5dcc89d948fa52f4a1b7c210585e9e5657004a431a4d177d7393d8283a9be86117e2c2452e4381399d1f479ae7b9ec4c5f891d09dd99c81768a64b69d8b182a SHA512 774612652537f46f486c0ae4157053463debcdc079d5e732865c729ef7fbab5f0d1b8da5d4e7cc1eda3a80250b43877d8f75889fa86330f951c61e3f8a7a29e2
diff --git a/dev-python/jupyter_core/jupyter_core-4.8.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.8.1.ebuild
new file mode 100644
index 000000000000..7d5e4f475698
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails if jupyter is not in system sitedir
+ # (PYTHONPATH is insufficient)
+ jupyter_core/tests/test_command.py::test_not_on_path
+ jupyter_core/tests/test_command.py::test_path_priority
+ # TODO
+ jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env
+)