summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-20 17:08:27 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-20 20:24:27 +0100
commit0d5d20f9c9e357e0a9991cec2c84fcbf96c4b171 (patch)
treeb733f58346c93fc9c9b9e27d82d86a651dd7e5f3 /dev-python/jupyter_events
parentdev-python/python-json-logger: new package, add 2.0.4 (diff)
downloadgentoo-0d5d20f9c9e357e0a9991cec2c84fcbf96c4b171.tar.gz
gentoo-0d5d20f9c9e357e0a9991cec2c84fcbf96c4b171.tar.bz2
gentoo-0d5d20f9c9e357e0a9991cec2c84fcbf96c4b171.zip
dev-python/jupyter_events: new package, add 0.5.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_events')
-rw-r--r--dev-python/jupyter_events/Manifest1
-rw-r--r--dev-python/jupyter_events/jupyter_events-0.5.0.ebuild35
-rw-r--r--dev-python/jupyter_events/metadata.xml17
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/jupyter_events/Manifest b/dev-python/jupyter_events/Manifest
new file mode 100644
index 000000000000..2f0669a0a419
--- /dev/null
+++ b/dev-python/jupyter_events/Manifest
@@ -0,0 +1 @@
+DIST jupyter_events-0.5.0.tar.gz 55838 BLAKE2B a3ac815a28d2592a10394569726b76de75cb3baab0bab4c1f276da33375ba93d6bfed71fbfaca404a238b7af58ebd7e75dd7fdf6c8717141517c2f790eeb9514 SHA512 49c21f0d5dce18b137f73911b0272919a56c972561deceb228558ea369f2091ce219ac335eec002b22ca1465b2622330fb3d8973d142df4b76e350345cb6249a
diff --git a/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild b/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
new file mode 100644
index 000000000000..24a0db98c961
--- /dev/null
+++ b/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.3.0[${PYTHON_USEDEP}]
+ dev-python/python-json-logger[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest
diff --git a/dev-python/jupyter_events/metadata.xml b/dev-python/jupyter_events/metadata.xml
new file mode 100644
index 000000000000..0b3c9998d541
--- /dev/null
+++ b/dev-python/jupyter_events/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-events</remote-id>
+ <remote-id type="github">jupyter/jupyter_events</remote-id>
+ </upstream>
+</pkgmetadata>