summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-13 13:54:39 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-13 13:56:23 +0100
commitfeac94d2e8f544d7791a120dddf5cfeaca20fdc8 (patch)
tree70f51068dff223fc747a18c04a4b3d9bf09dbbe0 /dev-python/jupyter_events
parentdev-python/ypy-websocket: restrict to aiofiles<23 (diff)
downloadgentoo-feac94d2e8f544d7791a120dddf5cfeaca20fdc8.tar.gz
gentoo-feac94d2e8f544d7791a120dddf5cfeaca20fdc8.tar.bz2
gentoo-feac94d2e8f544d7791a120dddf5cfeaca20fdc8.zip
dev-python/jupyter_events: add 0.5.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_events')
-rw-r--r--dev-python/jupyter_events/Manifest1
-rw-r--r--dev-python/jupyter_events/jupyter_events-0.5.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jupyter_events/Manifest b/dev-python/jupyter_events/Manifest
index ce2dff3ba391..e3ded81aafe5 100644
--- a/dev-python/jupyter_events/Manifest
+++ b/dev-python/jupyter_events/Manifest
@@ -1 +1,2 @@
+DIST jupyter_events-0.5.0.tar.gz 55838 BLAKE2B a3ac815a28d2592a10394569726b76de75cb3baab0bab4c1f276da33375ba93d6bfed71fbfaca404a238b7af58ebd7e75dd7fdf6c8717141517c2f790eeb9514 SHA512 49c21f0d5dce18b137f73911b0272919a56c972561deceb228558ea369f2091ce219ac335eec002b22ca1465b2622330fb3d8973d142df4b76e350345cb6249a
DIST jupyter_events-0.6.3.tar.gz 59393 BLAKE2B 0f747cc099e8b0e30024b7fa61007d4449fad1be3b4807021df28668969dca18087634606d6f2c453da81da9c107576133e13ec373cf34362d0182320e84e809 SHA512 a9b9c180f7b4759a3d2c99421947a837020149ec1a91ad0cd06971d7ae99ad1050652f01f78c9478ce3fd3f1a1ab6b579e90c279fcee0771546f3c346becd61f
diff --git a/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild b/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
new file mode 100644
index 000000000000..aa7f35f09849
--- /dev/null
+++ b/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+# jsonschema[format-nongpl] deps are always on in our ebuild
+RDEPEND="
+ >=dev-python/jsonschema-4.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest