summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-03 08:14:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-03 10:52:22 +0200
commit36f16675573503763b01d5dd9f6ff0603f3d4654 (patch)
tree683c3c291068c40cda3ddb88709dacb2d5c7fd3d /dev-python/jwcrypto
parentdev-python/xmlschema: Bump to 1.7.0 (diff)
downloadgentoo-36f16675573503763b01d5dd9f6ff0603f3d4654.tar.gz
gentoo-36f16675573503763b01d5dd9f6ff0603f3d4654.tar.bz2
gentoo-36f16675573503763b01d5dd9f6ff0603f3d4654.zip
dev-python/jwcrypto: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index ab5aa48b939a..69c5796c2c9e 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1 +1,2 @@
DIST jwcrypto-0.9.1.tar.gz 86363 BLAKE2B d5920b9471870855bc131c171dc5515cc23fb9b94c38b33ce4894bcbe6fb5d0fa87e8b88f6470b8d1c1a1bc158d0dd09f51ace50baab03c8a8df59adc6e7e11d SHA512 245221d5e570918c1db9abdad72a0b03fb3fbdbb4db46ece441cbd75d43246b1b35bfd75e20718b8fa125bcaa85088cd776a7c204dd68e51e63818ae438848eb
+DIST jwcrypto-1.0.0.tar.gz 87000 BLAKE2B 6e85d52c26447b07c3d06387ac9e3b7adf585d5dc320c633e80ca2bc1e327f01ac95cec9a0fe2b92f7f8ed7f5650d5ad1a95de500d328b33763d604aaba1bd62 SHA512 12d270219d289041098f875f5b2b0773ffbf9044996a6189b827cafbf3e5dccfc103915275b1a11dce2d50e3510510eea476b024d19cf97fd7c66c25de5b3dbf
diff --git a/dev-python/jwcrypto/jwcrypto-1.0.0.ebuild b/dev-python/jwcrypto/jwcrypto-1.0.0.ebuild
new file mode 100644
index 000000000000..59761ac07cbe
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+
+HOMEPAGE="https://github.com/latchset/jwcrypto"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -i "\|data_files = \[('share/doc/jwcrypto|d" setup.py || die
+ distutils-r1_python_prepare_all
+}