summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-31 02:01:52 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-31 02:01:52 -0700
commitf93be8b63efd69620d36c1ad6ce0d275751b5d4d (patch)
tree0a444c6f60bcaedd0c09dbf2fa8351f9c3037116 /dev-python/kconfiglib
parentmedia-video/mkvtoolnix: version bump to 43.0.0 (diff)
downloadgentoo-f93be8b63efd69620d36c1ad6ce0d275751b5d4d.tar.gz
gentoo-f93be8b63efd69620d36c1ad6ce0d275751b5d4d.tar.bz2
gentoo-f93be8b63efd69620d36c1ad6ce0d275751b5d4d.zip
dev-python/kconfiglib: version bump to 14.1.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/kconfiglib')
-rw-r--r--dev-python/kconfiglib/Manifest1
-rw-r--r--dev-python/kconfiglib/kconfiglib-14.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/kconfiglib/Manifest b/dev-python/kconfiglib/Manifest
index 068202d00b02..bcdee0c0c1ff 100644
--- a/dev-python/kconfiglib/Manifest
+++ b/dev-python/kconfiglib/Manifest
@@ -1,2 +1,3 @@
DIST kconfiglib-13.2.0.tar.gz 181115 BLAKE2B 81aeab65c4d7008dad33d508eb2be5ed53187943c1ec5112a87a47a5f9bb661c521b0d61a3da63da3233f168d62ab6bb5cdf6e3702e53f960159b7ca13c8a0cf SHA512 9d8c76014aa7faa93af216849859eca9bfdc0d4cd3e030e47b72acfdd4981ac1581747adf91bca58a4e8d86b151988309f36c3f94a1ebb216a1412fd004fafd2
DIST kconfiglib-13.7.0.tar.gz 182782 BLAKE2B 976a8e4e377933e42dc45c79598a175d302d34f48bfadd764c0cbfa2ddd4e15ae6ba22467c50d41657abbaa1f4495c556fb4c1deb9c96e1119a7bdd6ae8a3378 SHA512 0376b2c4e68b7ce4f105f52a3b4793a23cb844dbd9ab183abbdd79e2f7958e3be372024ce82295902af974f010c73c4ac97a4147bdac8ee9b52900bc15b8bb6f
+DIST kconfiglib-14.1.0.tar.gz 182990 BLAKE2B 1e5a5f7e6d1003f4fa005b2b08abfa17cbf9f6837d9320f313b23f19c6e9e7aa7c8fddf5ff38871634257ea050390b279becec0c4e0638cdb53182347217e937 SHA512 929a75f9b9f74ad7d4190c15d7178b94ee0a6d1fb71d85e2942935e3a9370a4f2483d8b49123d41d6610841ad9efde1dc4c14fc5231a08379d438a486ed3f97c
diff --git a/dev-python/kconfiglib/kconfiglib-14.1.0.ebuild b/dev-python/kconfiglib/kconfiglib-14.1.0.ebuild
new file mode 100644
index 000000000000..52b0349ecfe9
--- /dev/null
+++ b/dev-python/kconfiglib/kconfiglib-14.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="A flexible Python Kconfig implementation"
+HOMEPAGE="https://github.com/ulfalizer/Kconfiglib https://pypi.org/project/kconfiglib/"
+SRC_URI="https://github.com/ulfalizer/Kconfiglib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarballs don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P/k/K}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # hacks to run tests
+ mkdir Kconfiglib || die
+ ln -s ../tests Kconfiglib || die
+ # don't run kernel Kconfig compat tests
+ sed -i 's/run_compatibility_tests()$/#\0/' testsuite.py || die
+}
+
+python_test() {
+ "${PYTHON}" testsuite.py || die "tests failed with ${EPYTHON}"
+}