summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-05 17:43:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-05 18:03:52 +0200
commit9ab5cd9dd7eb30b5188e37e27f9b4489ecbd43ba (patch)
treed8ae8187e63e2946bb88fe84073b62359af3cda1 /dev-python/kiwisolver
parentdev-python/cppy: Port to py39 (diff)
downloadgentoo-9ab5cd9dd7eb30b5188e37e27f9b4489ecbd43ba.tar.gz
gentoo-9ab5cd9dd7eb30b5188e37e27f9b4489ecbd43ba.tar.bz2
gentoo-9ab5cd9dd7eb30b5188e37e27f9b4489ecbd43ba.zip
dev-python/kiwisolver: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kiwisolver')
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.2.0.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild b/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
index 3a1f79a66854..2d2ec37813ab 100644
--- a/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
+++ b/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
@@ -2,13 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
HOMEPAGE="https://github.com/nucleic/kiwi"
SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/kiwi-${PV}
LICENSE="Clear-BSD"
SLOT="0"
@@ -17,8 +18,5 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
RDEPEND="
>=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/kiwi-${PV}
distutils_enable_tests pytest