summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-04 22:49:25 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 22:50:36 +0100
commit228752b0954877a22e6d2b2017da4c1c72edf2b8 (patch)
treeca04bafd4ea4b47bcc14f253fb11bc06ecf25385 /dev-python/kombu
parentdev-python/keyrings_alt: Clean old up (diff)
downloadgentoo-228752b0954877a22e6d2b2017da4c1c72edf2b8.tar.gz
gentoo-228752b0954877a22e6d2b2017da4c1c72edf2b8.tar.bz2
gentoo-228752b0954877a22e6d2b2017da4c1c72edf2b8.zip
dev-python/kombu: Clean old up
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest1
-rw-r--r--dev-python/kombu/files/kombu-4.0.2-dict-iter.patch24
-rw-r--r--dev-python/kombu/kombu-4.0.2.ebuild76
3 files changed, 0 insertions, 101 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index da2cdfb47790..a69dcd6877c2 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,3 +1,2 @@
DIST kombu-3.0.37.tar.gz 411790 BLAKE2B 437e99beba410bd0e42b47e91b42fb8881443c8ccba454cb092adee94a94e93cb2104259b62652c423657c58f95a9969e0e966037040cc99e996e6daa7a8e2b7 SHA512 ba9bb00e23ce2d3da87eb07aacff8d63ef9879e6ca9f3fe82653cc2ee91610199fe8fc778d7c2e00df05b46130ecda0bdeceda48192b8af1fb0eca41fbb44712
-DIST kombu-4.0.2.tar.gz 418051 BLAKE2B 28328692519188fa67eda545ee06f56edc681ea5bebbed73cfabf812e0b544dd8f8cb8416cc930587e3f7658bb4b2701bfb0c8eb2005b3a3a9b506e9252a424c SHA512 99be6aa833eedc02897da90ebbd838bf0ac2a21db91350e235fae99ce31607cbc749f73f99d24f76acfc68b81d6263688d35b72ed62bb21d024a3ab385fa666e
DIST kombu-4.1.0.tar.gz 421875 BLAKE2B 636dab025883bc9465b28e7a6ab4249ae7d079cc57d33b1af8ce8633e12b85027ace9601475f9e2db1782d197f888476ce6006a2d5429e040ee8de0d1c86266c SHA512 fc104a3f974fabf090cc257b1a7623af6048f4630c6c2a9bb693fe69d77b6cdab36135a290a41056c1f854f61cce8fc2aa6b7880e9273581bfdfa162b5724861
diff --git a/dev-python/kombu/files/kombu-4.0.2-dict-iter.patch b/dev-python/kombu/files/kombu-4.0.2-dict-iter.patch
deleted file mode 100644
index fa3e545c6273..000000000000
--- a/dev-python/kombu/files/kombu-4.0.2-dict-iter.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 2940a4b1830bc2fc6d3f65de4feeec6ea5a49fe5 Mon Sep 17 00:00:00 2001
-From: Felix Yan <felixonmars@archlinux.org>
-Date: Tue, 21 Feb 2017 11:52:18 -0600
-Subject: [PATCH] Don't modify dict size while iterating over it (#676)
-
-This fixes https://github.com/celery/kombu/issues/675.
----
- kombu/messaging.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/kombu/messaging.py b/kombu/messaging.py
-index 03e7e15..e1800b5 100644
---- a/kombu/messaging.py
-+++ b/kombu/messaging.py
-@@ -397,7 +397,8 @@ def revive(self, channel):
- """Revive consumer after connection loss."""
- self._active_tags.clear()
- channel = self.channel = maybe_channel(channel)
-- for qname, queue in items(self._queues):
-+ # modify dict size while iterating over it is not allowed
-+ for qname, queue in list(items(self._queues)):
- # name may have changed after declare
- self._queues.pop(qname, None)
- queue = self._queues[queue.name] = queue(self.channel)
diff --git a/dev-python/kombu/kombu-4.0.2.ebuild b/dev-python/kombu/kombu-4.0.2.ebuild
deleted file mode 100644
index b5d030da5273..000000000000
--- a/dev-python/kombu/kombu-4.0.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="AMQP Messaging Framework for Python"
-HOMEPAGE="https://pypi.python.org/pypi/kombu https://github.com/celery/kombu"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples msgpack sqs test"
-
-# couchdb backend support possible via dev-python/couchdb-python
-# ditto dev-python/kazoo(>=1.3.1)
-RDEPEND="
- >=dev-python/py-amqp-2.1.4[${PYTHON_USEDEP}]
- dev-python/pyro:4[${PYTHON_USEDEP}]
- sqs? ( >=dev-python/boto-2.13.3[${PYTHON_USEDEP}] )
- msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )"
-# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.7[${PYTHON_USEDEP}]
- test? (
- >=dev-python/case-1.5.2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/redis-py-2.10.3[${PYTHON_USEDEP}]
- >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/couchdb-python[${PYTHON_USEDEP}]
- >=dev-python/sphinx_celery-1.1[${PYTHON_USEDEP}] )"
-
-# kazoo is optional for tests.
-# Refrain for now, no established demand for it from users
-
-# Req'd for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${P}-dict-iter.patch
- )
-
-python_prepare_all() {
- # AttributeError: test_Etcd instance has no attribute 'patch'
- rm t/unit/transport/test_etcd.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # Doc build misses and skips only content re librabbitmq which is not in portage
- if use doc; then
- emake -C docs html || die "kombu docs failed installation"
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}