summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 20:46:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 21:04:16 -0500
commit16add6200ad80d325688f79e19e15fcec524cfbd (patch)
tree509523c7169fb826de061ec831f2944c8f0dfacd /dev-python/lazr-delegates
parentdev-python/git-review: set DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-16add6200ad80d325688f79e19e15fcec524cfbd.tar.gz
gentoo-16add6200ad80d325688f79e19e15fcec524cfbd.tar.bz2
gentoo-16add6200ad80d325688f79e19e15fcec524cfbd.zip
dev-python/lazr-delegates: set DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/748315 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/lazr-delegates')
-rw-r--r--dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
index f326aa3dae97..26ee52990e7c 100644
--- a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
+++ b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
MY_PN=${PN/-/.}
@@ -18,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
+RDEPEND="
dev-python/zope-interface[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]"
+ dev-python/nose[${PYTHON_USEDEP}]
+"