summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 12:53:54 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 12:53:54 +0200
commit563adf54518c79f47376d0ae9d5e38779622515c (patch)
treee0e71f34c45c7103efcd9f01c1280dc8dfa95316 /dev-python/lesscpy
parentdev-python/kafka-python: Enable py3.9 (diff)
downloadgentoo-563adf54518c79f47376d0ae9d5e38779622515c.tar.gz
gentoo-563adf54518c79f47376d0ae9d5e38779622515c.tar.bz2
gentoo-563adf54518c79f47376d0ae9d5e38779622515c.zip
dev-python/lesscpy: Enable py3.9 & py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lesscpy')
-rw-r--r--dev-python/lesscpy/lesscpy-0.14.0.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/lesscpy/lesscpy-0.14.0.ebuild b/dev-python/lesscpy/lesscpy-0.14.0.ebuild
index 21e9b438e594..06eba5c57e17 100644
--- a/dev-python/lesscpy/lesscpy-0.14.0.ebuild
+++ b/dev-python/lesscpy/lesscpy-0.14.0.ebuild
@@ -1,15 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
-RESTRICT="!test? ( test )"
-
DESCRIPTION="A compiler written in Python for the LESS language"
HOMEPAGE="https://pypi.org/project/lesscpy/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -17,12 +13,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
-python_test() {
- nosetests -v || die "tests failed under ${EPYTHON}"
-}
+distutils_enable_tests nose