summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-12-20 06:50:41 -0600
committerMatthias Maier <tamiko@gentoo.org>2016-12-20 06:59:21 -0600
commit2de9da4bcffebaeef5566503746a850309a01007 (patch)
treedb8316dd150637bde06d8a97d9664d3fc46b668c /dev-python/libvirt-python
parentapp-emulation/libvirt: update live ebuild (diff)
downloadgentoo-2de9da4bcffebaeef5566503746a850309a01007.tar.gz
gentoo-2de9da4bcffebaeef5566503746a850309a01007.tar.bz2
gentoo-2de9da4bcffebaeef5566503746a850309a01007.zip
dev-python/libvirt-python: version bump to 2.5.0
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-2.5.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index e671d786698d..5777c71c44b8 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -4,3 +4,4 @@ DIST libvirt-python-2.1.0.tar.gz 170607 SHA256 74887fa1be60db2701e726da7e01e3bf1
DIST libvirt-python-2.2.0.tar.gz 171557 SHA256 ba6b2eb3f018275e9720498d7b771959c2d51ebd54f6e956de5055f912afea76 SHA512 d3c6679e8e9a7c875c89078733a4a8b25c65d7a37c1bad8ded7bffc1b16cac0c0db93fd5c5bfc8433cd6dd657d5d307a9bb38cc1178ecc5c730f8e03d5d6ae1d WHIRLPOOL 6f5d9360bae2c7611fadecf546c0159ae718cc932c0aa096622d80b58972f4623c7efa7979be7397b7ff4dc3906d3df0bebb5ff62f4d5a239ff45840bae78edb
DIST libvirt-python-2.3.0.tar.gz 171858 SHA256 ad25a98c2508a6c81d65cc8bc5f3e0b4c506247cf544a7d54c41526a99caef48 SHA512 87d3356c780f4f12a5dc7cf2b65d1d361b0572d476a207542118c276be1c46561d832c3ff7053affe06e0893f755af1f44d0a461c98980e9485363f827112b6b WHIRLPOOL 43d833296e5f750bf8e326dea76bfcee4947fe84eb5d0a1da6af160240da94354daf6b8b2f4d5eeb6dc5fcf7735c839e63a2e4844e07c56316e92279796fd0d0
DIST libvirt-python-2.4.0.tar.gz 171816 SHA256 aa087cca41f50296306baa13366948339b875fd722fc4b92a484484cd881120c SHA512 8a80e1a70d04666b9bd31ff64a00ac234823c1890734f00bfdbc17d85cdb9a96e40fab58f11cf755db13d04f864ba566a454609421176354ac5026b2777d3bba WHIRLPOOL b5abfaad509767f821db334fe5ea0825b35c71e55f2e4ca92071df60dac19fb955e16d6b0f2510ca215240402a260e1b2bdbf2b01d5cbbe240097e3c2b19c65b
+DIST libvirt-python-2.5.0.tar.gz 172329 SHA256 f4fd787ad26b4cd4b32afa65b6248c344ef48edffeb42c892c7adb4866f656d1 SHA512 2ff94ff12c20d9d0e5be8b571bc33fb1641e9940c6b49cdee37244c941674b12e1c980f9e0c73f4db52c91579ab19f92cea0c2e79a97abc67ee3309028661bb6 WHIRLPOOL 78712a122edfd4ce32e73332c8311e6b661be843f10ab30d3d85d426a266ddddbe36d30bfc09e63016189b8ffffe729119884d0d4acb05844b2bef37f8fadd63
diff --git a/dev-python/libvirt-python/libvirt-python-2.5.0.ebuild b/dev-python/libvirt-python/libvirt-python-2.5.0.ebuild
new file mode 100644
index 000000000000..3e3002d6c072
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-2.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}