summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-01-30 11:31:42 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-01-30 11:54:56 -0600
commit4d0b860f0afb2132cf1c8bef635e2a4f5e6e17fa (patch)
treef2034d946abb564d0cecd35a28d4072361003438 /dev-python/libvirt-python
parentapp-emulation/libvirt: version bump to 4.0.0 (diff)
downloadgentoo-4d0b860f0afb2132cf1c8bef635e2a4f5e6e17fa.tar.gz
gentoo-4d0b860f0afb2132cf1c8bef635e2a4f5e6e17fa.tar.bz2
gentoo-4d0b860f0afb2132cf1c8bef635e2a4f5e6e17fa.zip
dev-python/libvirt-python: version bump to 4.0.0
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index d5d8f73685f4..38ee8590036d 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-python-3.10.0.tar.gz 184402 BLAKE2B f3ae1626dc6fe2afc2eb7754f6872a6696389bc13a3e8f557c6487e83e3ef66104251910fb4841a2f8b1667cec0418b87ad5a7e9ababf76a39a0f4adaec23bc4 SHA512 bbab01d43b1d9e682c5590c1ea1454c8891f2c545b49f48220f4e79ec4b5b01ab1736242a96653256e26fdf644389c4021747117978a9ec4e1084001de9f23f9
DIST libvirt-python-3.8.0.tar.gz 184346 BLAKE2B 453051621c0e43eb73e0734a2a2651357f363c4f61c1cd6b883841a55e6c2338721b3e116e841a47386e12c8bdb1d36aecf9b8948876256effffd5396584a555 SHA512 40fcc67bf793b298016171751f207d65d98c8fe3e04d72bf4a815aab3c2f91a624fde1e0f1a420a67f4cf330874d7dd91ae46c3118e75067030ee551957a8178
+DIST libvirt-python-4.0.0.tar.gz 185533 BLAKE2B 3f9e3483265b18025bbfc0955c2b0b8276448c41e2d85a49ebc2d42f8dcd77af25a0a11ba04fbe02dba282a946ac3f583866c5d9fcda0d56e7a5f20dc63e7f94 SHA512 3eca33bb04265323ad47a6c8cb04a6848ab2b06bf656a188c7c0a39419e6dcc5c21f16682f6c64647da432c1d7e3ddc4699d848766987baccf806d68b5937d9a
diff --git a/dev-python/libvirt-python/libvirt-python-4.0.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.0.0.ebuild
new file mode 100644
index 000000000000..172f3dc38862
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-4.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}