summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-01 13:43:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-01 14:27:27 +0200
commitfb040924161851bb46dcbea975af4e4a8c98d6f7 (patch)
treef331c5752c41dc22eec52c1940fe7ebd959a99d3 /dev-python/line_profiler/line_profiler-3.5.1.ebuild
parentdev-python/phonenumbers: Bump to 8.12.46 (diff)
downloadgentoo-fb040924161851bb46dcbea975af4e4a8c98d6f7.tar.gz
gentoo-fb040924161851bb46dcbea975af4e4a8c98d6f7.tar.bz2
gentoo-fb040924161851bb46dcbea975af4e4a8c98d6f7.zip
dev-python/line_profiler: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler/line_profiler-3.5.1.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-3.5.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/line_profiler/line_profiler-3.5.1.ebuild b/dev-python/line_profiler/line_profiler-3.5.1.ebuild
new file mode 100644
index 000000000000..a631bb642adf
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+# force it to match scikit-build
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# technically, the package claims to support non-scikit-build build
+# but it's clearly unmaintained and broken at the moment
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd tests || die
+ epytest
+}