summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-27 21:38:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-27 21:54:41 +0100
commit4492f74b362b2f7c187c99f8629bc6284e599eb7 (patch)
treea6e734af8cbfc0ff8b2d63537a2601a6feb23c9c /dev-python/lit
parentsys-apps/iproute2: Removed old (diff)
downloadgentoo-4492f74b362b2f7c187c99f8629bc6284e599eb7.tar.gz
gentoo-4492f74b362b2f7c187c99f8629bc6284e599eb7.tar.bz2
gentoo-4492f74b362b2f7c187c99f8629bc6284e599eb7.zip
dev-python/lit: Set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-10.0.0.9999.ebuild3
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild3
-rw-r--r--dev-python/lit/lit-7.1.0.ebuild3
-rw-r--r--dev-python/lit/lit-8.0.1.ebuild3
-rw-r--r--dev-python/lit/lit-9.0.1.ebuild3
5 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/lit/lit-10.0.0.9999.ebuild b/dev-python/lit/lit-10.0.0.9999.ebuild
index 4996ccd73ba8..d53547c725e0 100644
--- a/dev-python/lit/lit-10.0.0.9999.ebuild
+++ b/dev-python/lit/lit-10.0.0.9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
inherit distutils-r1 llvm.org multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
@@ -19,7 +21,6 @@ RESTRICT="!test? ( test )"
# Tests require 'FileCheck' and 'not' utilities (from llvm)
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
index 4996ccd73ba8..d53547c725e0 100644
--- a/dev-python/lit/lit-11.0.0.9999.ebuild
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
inherit distutils-r1 llvm.org multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
@@ -19,7 +21,6 @@ RESTRICT="!test? ( test )"
# Tests require 'FileCheck' and 'not' utilities (from llvm)
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"
diff --git a/dev-python/lit/lit-7.1.0.ebuild b/dev-python/lit/lit-7.1.0.ebuild
index c9d754973b91..0d76068cd76e 100644
--- a/dev-python/lit/lit-7.1.0.ebuild
+++ b/dev-python/lit/lit-7.1.0.ebuild
@@ -3,7 +3,9 @@
EAPI=6
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
inherit distutils-r1 multiprocessing
MY_P=llvm-${PV/_/}.src
@@ -21,7 +23,6 @@ S=${WORKDIR}/${MY_P}/utils/lit
# Tests require 'FileCheck' and 'not' utilities (from llvm)
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"
diff --git a/dev-python/lit/lit-8.0.1.ebuild b/dev-python/lit/lit-8.0.1.ebuild
index 9fb91951383f..03682e862735 100644
--- a/dev-python/lit/lit-8.0.1.ebuild
+++ b/dev-python/lit/lit-8.0.1.ebuild
@@ -3,7 +3,9 @@
EAPI=6
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
inherit distutils-r1 multiprocessing
MY_P=llvm-${PV/_/}.src
@@ -21,7 +23,6 @@ S=${WORKDIR}/${MY_P}/utils/lit
# Tests require 'FileCheck' and 'not' utilities (from llvm)
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"
diff --git a/dev-python/lit/lit-9.0.1.ebuild b/dev-python/lit/lit-9.0.1.ebuild
index a3b7d11a88e3..c87eead5cb39 100644
--- a/dev-python/lit/lit-9.0.1.ebuild
+++ b/dev-python/lit/lit-9.0.1.ebuild
@@ -3,7 +3,9 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
inherit distutils-r1 llvm.org multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
@@ -19,7 +21,6 @@ RESTRICT="!test? ( test )"
# Tests require 'FileCheck' and 'not' utilities (from llvm)
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"