summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-18 17:40:45 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-18 18:18:30 +0100
commit5c2bc2db146dabc21b4fff2739697f3c6fac1f17 (patch)
treeea7bc0f467f4fe3bd27f6edf13265d51653d4b14 /dev-python/lit
parentsys-devel/llvmgold: Include 11.* ebuilds for master (diff)
downloadgentoo-5c2bc2db146dabc21b4fff2739697f3c6fac1f17.tar.gz
gentoo-5c2bc2db146dabc21b4fff2739697f3c6fac1f17.tar.bz2
gentoo-5c2bc2db146dabc21b4fff2739697f3c6fac1f17.zip
dev-python/lit: Include 11.* ebuilds for master
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
new file mode 100644
index 000000000000..4996ccd73ba8
--- /dev/null
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1 llvm.org multiprocessing
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
+}