summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-03-10 15:33:56 +0100
committerPacho Ramos <pacho@gentoo.org>2018-03-10 15:52:45 +0100
commit1b9bb513f2bc0b63cc70aedee3e4a761d52bc8b1 (patch)
treee047c1fd246e166d4cd067ade064550e297ec072 /dev-python/livereload
parentdev-python/livereload: Update maintainer due to bug #502560 (diff)
downloadgentoo-1b9bb513f2bc0b63cc70aedee3e4a761d52bc8b1.tar.gz
gentoo-1b9bb513f2bc0b63cc70aedee3e4a761d52bc8b1.tar.bz2
gentoo-1b9bb513f2bc0b63cc70aedee3e4a761d52bc8b1.zip
dev-python/livereload: Drop old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/livereload')
-rw-r--r--dev-python/livereload/Manifest2
-rw-r--r--dev-python/livereload/files/fix-tests.patch77
-rw-r--r--dev-python/livereload/livereload-2.3.2.ebuild41
-rw-r--r--dev-python/livereload/livereload-2.4.0.ebuild38
4 files changed, 0 insertions, 158 deletions
diff --git a/dev-python/livereload/Manifest b/dev-python/livereload/Manifest
index c945d6f980d3..27eb76253771 100644
--- a/dev-python/livereload/Manifest
+++ b/dev-python/livereload/Manifest
@@ -1,3 +1 @@
-DIST livereload-2.3.2.tar.gz 24119 BLAKE2B 9c91044133fa07d6e17c7b737aa8210d8c983e481b89fdf23c035014b98248e1e4a8613af16e9c6facc27be1d7f66102aed5cf293d836c513c9ab6f75f1e769f SHA512 59dc5be184d80a8b3aa6f98a6bc12f98f2efe00a0497deadfe5275222be2e0865e182cf0d83fc7a6e5f7297a7bf26a30c3ad9af5eeb2517af8b7ab3946e4bb1d
-DIST livereload-2.4.0.tar.gz 25258 BLAKE2B b597b49053d723e2c5656f34edb2bdc9d2d7e7f42556883cfb0861f9b062e81e0e4ffe17b1d4ce12c1ced0619171ce937080c2a212dd310ca0107e1bae08f987 SHA512 9b961ed41224359e986873973840fae43387af1b773328ab1262d095879aeff98090d736d696abdfcd9b2f1c127a061a29d044df7cfa15ba218b0162576093a3
DIST livereload-2.4.1.tar.gz 25593 BLAKE2B 97a37349f14cb9d1841ec78cc3d1965b59f65f86b00cb972b9b726364f7f34e6409853f8af32215c6bd400698f9b3ac2b947ac7864a8df15ccec8badddaa0cfe SHA512 9106fe1894092ab336270f539be41d4db2d277560a41898e45014e34783ab0b601c993a5a5831c951d313db98ea835aecc8eb31468ba186e243a28df75bfe9bb
diff --git a/dev-python/livereload/files/fix-tests.patch b/dev-python/livereload/files/fix-tests.patch
deleted file mode 100644
index 2c9208ad17aa..000000000000
--- a/dev-python/livereload/files/fix-tests.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/tests/test_watcher.py b/tests/test_watcher.py
-index fa0ae41..5310bdc 100644
---- a/tests/test_watcher.py
-+++ b/tests/test_watcher.py
-@@ -3,18 +3,22 @@
- import os
- import time
- import shutil
-+import unittest
- from livereload.watcher import Watcher
-
- tmpdir = os.path.join(os.path.dirname(__file__), 'tmp')
-
-
--class TestWatcher(object):
-+class TestWatcher(unittest.TestCase):
-
- def setUp(self):
- if os.path.isdir(tmpdir):
- shutil.rmtree(tmpdir)
- os.mkdir(tmpdir)
-
-+ def tearDown(self):
-+ shutil.rmtree(tmpdir)
-+
- def test_watch_dir(self):
- os.mkdir(os.path.join(tmpdir, '.git'))
- os.mkdir(os.path.join(tmpdir, '.hg'))
-@@ -25,6 +29,9 @@ class TestWatcher(object):
- watcher.watch(tmpdir)
- assert watcher.is_changed(tmpdir) is False
-
-+ # sleep 1 second so that mtime will be different
-+ time.sleep(1)
-+
- with open(os.path.join(tmpdir, 'foo'), 'w') as f:
- f.write('')
-
-@@ -35,6 +42,9 @@ class TestWatcher(object):
- watcher = Watcher()
- watcher.count = 0
-
-+ # sleep 1 second so that mtime will be different
-+ time.sleep(1)
-+
- filepath = os.path.join(tmpdir, 'foo')
- with open(filepath, 'w') as f:
- f.write('')
-@@ -51,22 +61,24 @@ class TestWatcher(object):
- with open(filepath, 'w') as f:
- f.write('')
-
-- assert watcher.examine() == os.path.abspath(filepath)
-+ rv = watcher.examine()
-+ assert rv[0] == os.path.abspath(filepath)
- assert watcher.count == 1
-
- def test_watch_glob(self):
- watcher = Watcher()
- watcher.watch(tmpdir + '/*')
-- assert watcher.examine() is None
-+ assert watcher.examine() == (None, None)
-
- with open(os.path.join(tmpdir, 'foo.pyc'), 'w') as f:
- f.write('')
-
-- assert watcher.examine() is None
-+ assert watcher.examine() == (None, None)
-
- filepath = os.path.join(tmpdir, 'foo')
-
- with open(filepath, 'w') as f:
- f.write('')
-
-- assert watcher.examine() == os.path.abspath(filepath)
-+ rv = watcher.examine()
-+ assert rv[0] == os.path.abspath(filepath)
diff --git a/dev-python/livereload/livereload-2.3.2.ebuild b/dev-python/livereload/livereload-2.3.2.ebuild
deleted file mode 100644
index 53379d37ad1d..000000000000
--- a/dev-python/livereload/livereload-2.3.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python LiveReload is an awesome tool for web developers"
-HOMEPAGE="https://github.com/lepture/python-livereload"
-SRC_URI="https://github.com/lepture/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="www-servers/tornado[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/fix-tests.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( example/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/livereload/livereload-2.4.0.ebuild b/dev-python/livereload/livereload-2.4.0.ebuild
deleted file mode 100644
index f6eee14f1ff5..000000000000
--- a/dev-python/livereload/livereload-2.4.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python LiveReload is an awesome tool for web developers"
-HOMEPAGE="https://github.com/lepture/python-livereload"
-SRC_URI="https://github.com/lepture/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples test"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="
- ${CDEPEND}
- dev-python/six[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
-"
-
-python_test() {
- nosetests || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( example/. )
-
- distutils-r1_python_install_all
-}