summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-01 10:34:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-01 10:53:33 +0200
commit243e4816f562279a2fa56613c91c92f66324236c (patch)
tree435a1c609288bc651196ec96b8ce7117d0b4cb22 /dev-python/llvmlite
parentdev-ada/gps: Remove old (LLVM 7) (diff)
downloadgentoo-243e4816f562279a2fa56613c91c92f66324236c.tar.gz
gentoo-243e4816f562279a2fa56613c91c92f66324236c.tar.bz2
gentoo-243e4816f562279a2fa56613c91c92f66324236c.zip
dev-python/llvmlite: Remove old (LLVM 7)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/files/llvmlite-0.28.0-llvm710.patch59
-rw-r--r--dev-python/llvmlite/llvmlite-0.28.0.ebuild63
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index aa63505e0fa8..aee8d21a2e8e 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,3 +1,2 @@
-DIST llvmlite-0.28.0.gh.tar.gz 191141 BLAKE2B 23c86c28311a4e8c7f9c209a7ed7816ad5002c26f9fda7a47cf2b54c4578db28ed0781b54a716726db8a7c1abce79a79a99c3f5bf4be2a61d547eb74d06cb507 SHA512 c00c767c80a507975a055088ca4328766c992e7267219dea54376daf5eb11397532b243352976d3569185149007650d5e94839b61aa55502e1991f72b1ba492a
DIST llvmlite-0.29.0.gh.tar.gz 196507 BLAKE2B d4870ca042d446857b7409c0c50c370458747ee744c24611e88da4bc8780c26125b2e8db3db7fe9d4f553f9aae5769b62effe1ac94cfaf234bab54d43c8086e9 SHA512 8735b46b1a3053b89306bf6e05c8c6c375d15371d33635f1d27e5533d7a78a85f773e04b7ed8d39ebab40a892c374839e1324665d81459cb797f760d6d2c81d1
DIST llvmlite-0.30.0.gh.tar.gz 199354 BLAKE2B 71ba1b0572d115a28d838a7fa5daca136fb793d41cdebca5834d2977813b4a02837e99d8b1b48d0fa965c5d3bdfe7783314ecbd2a7e7075b82247ea5fa4f90a4 SHA512 e3a64a3170efe1bffb6eeb8d6cfdc5a9bf8cc9e123da0b317b6b8dd93dacd3a54d5117c22eca43226915e7ff2793ab66cdee00c5e6ada442d9c2f7fed6e40763
diff --git a/dev-python/llvmlite/files/llvmlite-0.28.0-llvm710.patch b/dev-python/llvmlite/files/llvmlite-0.28.0-llvm710.patch
deleted file mode 100644
index db06adb41c1a..000000000000
--- a/dev-python/llvmlite/files/llvmlite-0.28.0-llvm710.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 3845caca60120a8f9a094833e44bc4184b1d6827 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 21 Apr 2019 13:56:00 +0200
-Subject: [PATCH] Permit building against LLVM 7.1.0
-
-Restrict building to any 7.* version rather than 7.0.*, as 7.1.0 has
-been released that is API-compatible with 7.0.*.
----
- README.rst | 2 +-
- ffi/build.py | 4 ++--
- llvmlite/tests/test_binding.py | 3 ++-
- 3 files changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/README.rst b/README.rst
-index 2462e3f..8e551eb 100644
---- a/README.rst
-+++ b/README.rst
-@@ -70,7 +70,7 @@ Historical compatibility table:
- ================= ========================
- llvmlite versions compatible LLVM versions
- ================= ========================
--0.27.0 - ... 7.0.x
-+0.27.0 - ... 7.y.x
- 0.23.0 - 0.26.0 6.0.x
- 0.21.0 - 0.22.0 5.0.x
- 0.17.0 - 0.20.0 4.0.x
-diff --git a/ffi/build.py b/ffi/build.py
-index 7d5247d..a87e857 100755
---- a/ffi/build.py
-+++ b/ffi/build.py
-@@ -109,9 +109,9 @@ def main_posix(kind, library_ext):
-
- out = out.decode('latin1')
- print(out)
-- if not out.startswith('7.0.'):
-+ if not out.startswith('7.'):
- msg = (
-- "Building llvmlite requires LLVM 7.0.x. Be sure to "
-+ "Building llvmlite requires LLVM 7.y.x. Be sure to "
- "set LLVM_CONFIG to the right executable path.\n"
- "Read the documentation at http://llvmlite.pydata.org/ for more "
- "information about building llvmlite.\n"
-diff --git a/llvmlite/tests/test_binding.py b/llvmlite/tests/test_binding.py
-index 335c30d..134f356 100644
---- a/llvmlite/tests/test_binding.py
-+++ b/llvmlite/tests/test_binding.py
-@@ -339,7 +339,8 @@ class TestMisc(BaseTest):
-
- def test_version(self):
- major, minor, patch = llvm.llvm_version_info
-- self.assertEqual((major, minor), (7, 0))
-+ self.assertEqual(major, 7)
-+ self.assertIn(minor, (0, 1))
- self.assertIn(patch, range(10))
-
- def test_check_jit_execution(self):
---
-2.21.0
-
diff --git a/dev-python/llvmlite/llvmlite-0.28.0.ebuild b/dev-python/llvmlite/llvmlite-0.28.0.ebuild
deleted file mode 100644
index ccc4a40f973c..000000000000
--- a/dev-python/llvmlite/llvmlite-0.28.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="http://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-LLVM_MAX_SLOT=7
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${P/_/}
-
-PATCHES=(
- "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
- "${FILESDIR}"/llvmlite-0.28.0-llvm710.patch
-)
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}