summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-11 08:59:40 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-11 09:25:27 +0200
commit6fda1d87d7e4f662e0be7ba12bf1516adbfdc8d9 (patch)
tree53d998887cd749920cb36dd3ed6a851c52ea8554 /dev-python/llvmlite
parentdev-util/cargo: tweak the build command and die early (diff)
downloadgentoo-6fda1d87d7e4f662e0be7ba12bf1516adbfdc8d9.tar.gz
gentoo-6fda1d87d7e4f662e0be7ba12bf1516adbfdc8d9.tar.bz2
gentoo-6fda1d87d7e4f662e0be7ba12bf1516adbfdc8d9.zip
dev-python/llvmlite: Bump to 25.0_rc1
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.25.0_rc1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 9cf1b791f294..bfabd9338c58 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,3 +1,4 @@
DIST llvmlite-0.20.0.tar.gz 96753 BLAKE2B ec9cfa554f44162c0d6e755628603c9afd85642998f56ed49c2ff29c3ef975ef4ce14c6555382ca282b70d71a1ff7347c0b773b339b14345e10d3b9ac96ac55e SHA512 c2e0918e7acfba68922f60889180ec660da13ea199c9e8dfb3ac075c295baeb8c90784a6acc3c463cdd696f8f61c42226548d38db5bd8c4397a23cfa7c7ff764
DIST llvmlite-0.22.0.gh.tar.gz 156077 BLAKE2B 1b95a0636807fcf38955b32bd5c7c19784df2cc6708f23624c047f0e9caf4eb2fc26c7a1cb778d7cc7e42b8aeaee1ed43c92bcdaf7eb2e798c25f692b96b786a SHA512 633ec4d294dc246ebff5c7931e9bea86efa28323242411f3f54bc34c99085ebaef477b5bfd8224080790a12b188308ff9662c284b360e1a2939f4fe9b84a9458
DIST llvmlite-0.24.0.gh.tar.gz 169577 BLAKE2B 7fedf8b9ec49f537db27a77c5880fb3bb41d126c615e73a4fd503ff781dcd4745c4f708cccd31d9b5544609ab7821e8ef1299856ef13ec3912ad2341af12a3ce SHA512 14b8918f9f58a88596607e697212aa516a99c65f71257d22f09e6b735f517a38f11142a63bf2e8f117c6ceff97153a5e686fa322d62abd14000db7e9ae136900
+DIST llvmlite-0.25.0rc1.gh.tar.gz 173302 BLAKE2B 20d5596e4c1b0fad64ae29f8ed4f7541b57668f12058d77595993db9c1adda97da2355a6dee266aa34bee39cddaffb92dcf6b4820afb1619d975f1e4b2331cda SHA512 0252d717f9f59dbf35333f1c207847a7b004e3e8c0094fc0639c64c9d09a90b370c814e219ee949ebecc49c5f2230831d566d00924e610b29674fbed93acc7e5
diff --git a/dev-python/llvmlite/llvmlite-0.25.0_rc1.ebuild b/dev-python/llvmlite/llvmlite-0.25.0_rc1.ebuild
new file mode 100644
index 000000000000..c882b6bc8644
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.25.0_rc1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=6
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-devel/llvm-6.0.0-r1:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${P/_/}
+
+PATCHES=(
+ "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
+)
+
+python_prepare_all() {
+ # disable -flto, we do not force it against user's wishes
+ # add -fPIC, needed to link against shared libraries
+ # plus use those vars to force our CXXFLAGS/LDFLAGS in...
+ export CXX_FLTO_FLAGS="${CXXFLAGS} -fPIC"
+ export LD_FLTO_FLAGS="${LDFLAGS} -fPIC"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}