summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-30 13:27:59 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-30 13:27:59 +0200
commit871a90b5ac25766433d7f3c762f63d339c2f3b72 (patch)
treeec280c610400373315a22674cfca67c847690be2 /dev-python/llvmlite
parentdev-python/llvmlite: Bump to 0.29.0 (no changes from rc1) (diff)
downloadgentoo-871a90b5ac25766433d7f3c762f63d339c2f3b72.tar.gz
gentoo-871a90b5ac25766433d7f3c762f63d339c2f3b72.tar.bz2
gentoo-871a90b5ac25766433d7f3c762f63d339c2f3b72.zip
dev-python/llvmlite: Remove 0.29.0_rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 1b64d68291b8..4c16a5cc83d9 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -5,4 +5,3 @@ DIST llvmlite-0.27.0.gh.tar.gz 186891 BLAKE2B c7175beeb5c45b6fda62b78b23352d1c22
DIST llvmlite-0.27.1.gh.tar.gz 186904 BLAKE2B ee3af4b3ec03799ea6e643e0ee0a793537c46427d239fb3a26abf4a719b68432f403367321345c30a95758ce1bce411495bc48273dbf2452a872a1edd67dc9a4 SHA512 365ffd95050a39269d9f806d3969657437111b8e999db6cf03d0d99fc5bcc024dbc08f1d379745572317f8d4384d7f86095216674695c34f463a0b9bf48a8be7
DIST llvmlite-0.28.0.gh.tar.gz 191141 BLAKE2B 23c86c28311a4e8c7f9c209a7ed7816ad5002c26f9fda7a47cf2b54c4578db28ed0781b54a716726db8a7c1abce79a79a99c3f5bf4be2a61d547eb74d06cb507 SHA512 c00c767c80a507975a055088ca4328766c992e7267219dea54376daf5eb11397532b243352976d3569185149007650d5e94839b61aa55502e1991f72b1ba492a
DIST llvmlite-0.29.0.gh.tar.gz 196507 BLAKE2B d4870ca042d446857b7409c0c50c370458747ee744c24611e88da4bc8780c26125b2e8db3db7fe9d4f553f9aae5769b62effe1ac94cfaf234bab54d43c8086e9 SHA512 8735b46b1a3053b89306bf6e05c8c6c375d15371d33635f1d27e5533d7a78a85f773e04b7ed8d39ebab40a892c374839e1324665d81459cb797f760d6d2c81d1
-DIST llvmlite-0.29.0rc1.gh.tar.gz 196498 BLAKE2B 6db47948ac38bf61df7bf5eef60a29ac710d259b9b3fdcf8d9cb52239de85211969a34f707c155170e5b42d060e2d3e8616cf1b7720ebc808bddcc427a144bc9 SHA512 80f06584d52fe5947a06eec9ee88ba51c29847f53b4a2c9b21c660478c9e3f873f80677ebcffe1678e327d1132170bdc97737c385823ca0cbbfa9d9f1158cc0a
diff --git a/dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild b/dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild
deleted file mode 100644
index 98ff820616ca..000000000000
--- a/dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="http://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-LLVM_MAX_SLOT=8
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
- virtual/python-enum34[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${P/_/}
-
-PATCHES=(
- "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
-)
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}