summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:47:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:50:43 +0200
commitcf99b762e17c5be66b9f1b4dcef69d80298b6af8 (patch)
tree16adcad41c6993f8be1e0734217b81ac44855d3b /dev-python/llvmlite
parentdev-python/libtmux: Remove old (diff)
downloadgentoo-cf99b762e17c5be66b9f1b4dcef69d80298b6af8.tar.gz
gentoo-cf99b762e17c5be66b9f1b4dcef69d80298b6af8.tar.bz2
gentoo-cf99b762e17c5be66b9f1b4dcef69d80298b6af8.zip
dev-python/llvmlite: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch32
-rw-r--r--dev-python/llvmlite/llvmlite-0.33.0.ebuild66
3 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index ca5ee0901d5b..0ab640394b0e 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,2 +1 @@
-DIST llvmlite-0.33.0.gh.tar.gz 196450 BLAKE2B 3b1842b53eabf5cbc30aa642e12d214bd0cf8473f39873ad2b83de830a251ceac20281e2c8a528fff4623faeebf1583ab539cac74587bcb49ccaac22c922a16f SHA512 50b35db717ccc9d78cb7faa2e0b43cf4a622c5fca662ceb18c14163a26456fb79ed844db9a50e4566a2ea5c26089a419ca130d16b18a2486d4137e8a410ee3b9
DIST llvmlite-0.34.0.gh.tar.gz 210438 BLAKE2B 832ec28047a51b2874a0de5885445b9d77942a70f86620dfb0b25ff0b17395b6009d31d5e9f27ddf02c19ae97bd5b325fc49227fdc0499a9f5fa3bde44e6b564 SHA512 5540df4ebad835e294c00cc09ab1230a530566f563f751f890752f6e22f7b2a04aedcbb53dbbb8e323198d05c80bc9699b593d919eaf1af60fa6f94ff6f50bb1
diff --git a/dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch b/dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch
deleted file mode 100644
index b6c4242e4459..000000000000
--- a/dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 87a2de4b22e141d37b796dce77a6daef243145eb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 11 Jun 2020 09:22:32 +0200
-Subject: [PATCH] Use std::make_unique on LLVM 10
-
-LLVM 10 removes llvm::make_unique in favor of std::make_unique.
-However, this requires C++14 and is therefore unsuitable for LLVM 9
-that forces -std=c++11. Update the code to use both conditionally.
-This fixes all issues with LLVM 10.
----
- ffi/linker.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/ffi/linker.cpp b/ffi/linker.cpp
-index 57bb80b..585b261 100644
---- a/ffi/linker.cpp
-+++ b/ffi/linker.cpp
-@@ -42,7 +42,11 @@ LLVMPY_LinkModules(LLVMModuleRef Dest, LLVMModuleRef Src, const char **Err)
- auto OldDiagnosticHandler = Ctx.getDiagnosticHandler();
-
- // set the handler to a new one
-+#if LLVM_VERSION_MAJOR >= 10
-+ Ctx.setDiagnosticHandler(std::make_unique<ReportNotAbortDiagnosticHandler>(errstream));
-+#else
- Ctx.setDiagnosticHandler(llvm::make_unique<ReportNotAbortDiagnosticHandler>(errstream));
-+#endif
-
- // link
- bool failed = LLVMLinkModules2(Dest, Src);
---
-2.27.0
-
diff --git a/dev-python/llvmlite/llvmlite-0.33.0.ebuild b/dev-python/llvmlite/llvmlite-0.33.0.ebuild
deleted file mode 100644
index 89ee4202cbb9..000000000000
--- a/dev-python/llvmlite/llvmlite-0.33.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="https://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-S=${WORKDIR}/${P/_/}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-LLVM_MAX_SLOT=9
-
-RDEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- # test_version hardcodes permitted versions
- # test_parse* relies on exact error message
- sed -e 's:test_version:_&:' \
- -e 's:test_parse_bitcode_error:_&:' \
- -i llvmlite/tests/test_binding.py || die
-
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-
- export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}