summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/llvmmath
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/llvmmath')
-rw-r--r--dev-python/llvmmath/Manifest1
-rw-r--r--dev-python/llvmmath/llvmmath-0.1.2.ebuild29
-rw-r--r--dev-python/llvmmath/metadata.xml16
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/llvmmath/Manifest b/dev-python/llvmmath/Manifest
new file mode 100644
index 000000000000..dca80d6215c1
--- /dev/null
+++ b/dev-python/llvmmath/Manifest
@@ -0,0 +1 @@
+DIST llvmmath-0.1.2.tar.gz 46693 SHA256 6664988134572340eb01591c92f74b0ecf39a8e892a81c76274862b80944bda3 SHA512 7ac7a58d0c76d4badaa67b71ec852d9d87411edc3e0c16283741ba183fcee4b6c775d9e61c66b7c6bab24939796abecff6fe5ed06028e5635d8883dbb16d2f6c WHIRLPOOL 674be56ec12298c19e8ae7e0aa3cf33f72a7dda3e851c165eecf3d529cafa50d1991854fe199a3b8b467eb7a365931327a94545ca1e643af098a66f20a80428c
diff --git a/dev-python/llvmmath/llvmmath-0.1.2.ebuild b/dev-python/llvmmath/llvmmath-0.1.2.ebuild
new file mode 100644
index 000000000000..8851209d1c7d
--- /dev/null
+++ b/dev-python/llvmmath/llvmmath-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="LLVM math library for Python"
+HOMEPAGE="https://github.com/ContinuumIO/llvmmath"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/llvmpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c 'import sys,llvmmath; sys.exit(llvmmath.test())' || die
+}
diff --git a/dev-python/llvmmath/metadata.xml b/dev-python/llvmmath/metadata.xml
new file mode 100644
index 000000000000..3a2c2a56ccf3
--- /dev/null
+++ b/dev-python/llvmmath/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The purpose of this project is to provide portable math functions,
+ many of which are in C99 and not available on all platforms. It is
+ based on NumPy's umath and tries to support all floating point and
+ complex types.
+ The library can be compiled with any C compiler, or to LLVM assembly
+ using Clang, to be linked into modules containing functions for jitting.
+</longdescription>
+ <upstream>
+ <remote-id type="github">ContinuumIO/llvmmath</remote-id>
+ </upstream>
+</pkgmetadata>