summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-28 06:40:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-28 07:05:32 +0100
commit342504757fc280923f5d410a1a6e7e136e31a757 (patch)
tree122e4bc51a901e98502071fb731cdf4397a3e974 /dev-python/lmfit
parentdev-python/cryptography: Bump to 38.0.4 (diff)
downloadgentoo-342504757fc280923f5d410a1a6e7e136e31a757.tar.gz
gentoo-342504757fc280923f5d410a1a6e7e136e31a757.tar.bz2
gentoo-342504757fc280923f5d410a1a6e7e136e31a757.zip
dev-python/lmfit: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lmfit')
-rw-r--r--dev-python/lmfit/Manifest1
-rw-r--r--dev-python/lmfit/lmfit-1.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/lmfit/Manifest b/dev-python/lmfit/Manifest
index d546c944bfae..d954bfaa80ad 100644
--- a/dev-python/lmfit/Manifest
+++ b/dev-python/lmfit/Manifest
@@ -1 +1,2 @@
DIST lmfit-1.0.3.tar.gz 292475 BLAKE2B 6d97fe671b0d5bb7751d0ead97ab83d8100e2bb16b81bed61ff07ee6355bffd99258ab554032c9b8a35bb4376a1efef0ab988b3eb6d5a9e26f52314719e45dae SHA512 33febdd68104bb41ca379a8acd03a8bb985ba8785d607ab110b63bc7b3b39b9d95161a683fe015613bee6d99100ede82d1f3574515a6bfb9160300a5791fcc55
+DIST lmfit-py-1.1.0.gh.tar.gz 300406 BLAKE2B b874efd70bc1c5fa2c94239027d636a8dd5bf5ca2a3481cfc467032efe9d57ff55c74ccf175f32c6f87cd285e9216db49ef4fb0566e86cafe85537a40db64366 SHA512 9d5c871446a5bb650d8709b0db100e23be8ed7459ceb7ea4614fb07b1058044bb07394b2af615ecf7d9a22aaf49c1da723cb555749956d1f3ad507a4465fa0da
diff --git a/dev-python/lmfit/lmfit-1.1.0.ebuild b/dev-python/lmfit/lmfit-1.1.0.ebuild
new file mode 100644
index 000000000000..0200aee91e87
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=lmfit-py-${PV}
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="
+ https://lmfit.github.io/lmfit-py/
+ https://github.com/lmfit/lmfit-py/
+ https://pypi.org/project/lmfit/
+"
+SRC_URI="
+ https://github.com/lmfit/lmfit-py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asteval-0.9.28[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_model.py::TestUserDefiniedModel::test_model_nan_policy
+ )
+
+ epytest -o addopts=
+}