summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-20 09:14:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-20 09:26:46 +0100
commit3e00a3b69345aa46d6e567f6f8149d35731d4fe7 (patch)
treecfcdd90a10504f4ba25f2dc4c280a974bc335b4c /dev-python/locket
parentdev-python/readthedocs-sphinx-ext: Bump to 2.1.3 (diff)
downloadgentoo-3e00a3b69345aa46d6e567f6f8149d35731d4fe7.tar.gz
gentoo-3e00a3b69345aa46d6e567f6f8149d35731d4fe7.tar.bz2
gentoo-3e00a3b69345aa46d6e567f6f8149d35731d4fe7.zip
dev-python/locket: Bump to 0.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/locket')
-rw-r--r--dev-python/locket/Manifest1
-rw-r--r--dev-python/locket/locket-0.2.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/locket/Manifest b/dev-python/locket/Manifest
index e2eebd981c7e..fdff951378df 100644
--- a/dev-python/locket/Manifest
+++ b/dev-python/locket/Manifest
@@ -1 +1,2 @@
DIST locket.py-0.2.0.gh.tar.gz 5598 BLAKE2B 9b8a1b3d4c3fed3e9ab8f37a1e7bd9d0aa65e618985368691802b1b66d0dbdeb7a1635ff72efec8a7351ce31ffc00413d5ee388e520057bf181a18a39ef46f0a SHA512 e5e5d34daf5c36b0ac4871ce0dec50c67b504be16755e38d7721e40c4f2c385c022c305ac1a9bd641ba9eaf45a2693a4a77b6fa6e95d6ae5ab34947e4ac30393
+DIST locket.py-0.2.1.gh.tar.gz 5988 BLAKE2B e50ef1794a49494434c730580510a4283685e924f6f3efb95067db7d566fa4808409fc339f3c8e3276ddf09f622cb165e9dde90094f764f662558ea32f85516e SHA512 517c580a3420283f945d28607fc765c571edb2c0fab52d5c76f24226d2ec85727d1ffe0c03c5f87f6ce6204e7db4d3c8f6e408d767a389bd93d34cc0de3e8bf7
diff --git a/dev-python/locket/locket-0.2.1.ebuild b/dev-python/locket/locket-0.2.1.ebuild
new file mode 100644
index 000000000000..bf78cf9c96a9
--- /dev/null
+++ b/dev-python/locket/locket-0.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=locket.py-${PV}
+DESCRIPTION="File-based locks for Python"
+HOMEPAGE="https://github.com/mwilliamson/locket.py"
+SRC_URI="
+ https://github.com/mwilliamson/locket.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? ( dev-python/spur[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests nose