summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-10 08:02:24 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-11 23:26:30 +0100
commit0dc8b7dbdeecc1dac7165dca6e6b46777f863b38 (patch)
treeb5127c64784b261e629a9ea9aeb59d2fa5d33fc7 /dev-python/lz4
parentgnome-base/nautilus: bump to 3.30.5 (diff)
downloadgentoo-0dc8b7dbdeecc1dac7165dca6e6b46777f863b38.tar.gz
gentoo-0dc8b7dbdeecc1dac7165dca6e6b46777f863b38.tar.bz2
gentoo-0dc8b7dbdeecc1dac7165dca6e6b46777f863b38.zip
dev-python/lz4: version 2.1.6 bump.
Closes: https://bugs.gentoo.org/663570 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11324 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-2.1.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 1879b1d64955..1befb754dbe4 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1,2 +1,3 @@
DIST lz4-0.10.1.tar.gz 92068 BLAKE2B e581540036d1008c5efa008a1b980c1bd612bab94635b7a506e230921bd17c534fb99272e3ea09bc5be4faf09e0a8f701224c433df1615b4e708d620a23e1149 SHA512 538880742257e08b027c45c33aa29e12d7303826f63817d1f6d316ea9b69dfb20710a4f573499ce141cffd12fbac701305405521cb815e2329333934e7e1f2c9
DIST lz4-0.8.2.tar.gz 30818 BLAKE2B ec51d733ebd33fcb00d3d3b634d11be39d92b14741a595139e23b5b067955a43ca325a0a655233a5ae3a62e18a1cf70cc21787d443703fc1a56ab7a765d5e2f4 SHA512 e516d5c3309f214fa422b040a0aacdda079395624dd4f5548ed7af637b1594012aac75b309cef260b41c10a623410f815fc089b54ca5d80955d5f2ead12841b1
+DIST lz4-2.1.6.tar.gz 129066 BLAKE2B 1a739c54946150441ddd4025b4ce8bf79a718d64a714ca5cfeaf8712c73fa88c47e1823a08ec7ad50acd31cba5bc10292f4c9e0905d8b5965b789944dd6eca9f SHA512 e37f9576f182adab263d8248e846c9f7d8a0260b2d2c5f94d74ebf3c2e51d91ba07d4bb0bf8a7560981a930fd380a2a3f5c4d21f4de5be3ae066d44a2246e9b5
diff --git a/dev-python/lz4/lz4-2.1.6.ebuild b/dev-python/lz4/lz4-2.1.6.ebuild
new file mode 100644
index 000000000000..b1f535b1d153
--- /dev/null
+++ b/dev-python/lz4/lz4-2.1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/lz4"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+"