summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-05-08 12:02:53 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-05-08 13:34:12 -0700
commit1481a88b401bdefec806c0ba182f0277840259fd (patch)
treece7ae8cb189fe70429152cf954e0376566b28f57 /dev-python/lz4
parentdev-python/backports-weakref: Add python-3.8 (diff)
downloadgentoo-1481a88b401bdefec806c0ba182f0277840259fd.tar.gz
gentoo-1481a88b401bdefec806c0ba182f0277840259fd.tar.bz2
gentoo-1481a88b401bdefec806c0ba182f0277840259fd.zip
dev-python/lz4: Version bump, adds python-3.8
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch19
-rw-r--r--dev-python/lz4/lz4-3.0.2.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index accecfd18208..e8bc570e35f9 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1,2 +1,3 @@
DIST lz4-0.8.2.tar.gz 30818 BLAKE2B ec51d733ebd33fcb00d3d3b634d11be39d92b14741a595139e23b5b067955a43ca325a0a655233a5ae3a62e18a1cf70cc21787d443703fc1a56ab7a765d5e2f4 SHA512 e516d5c3309f214fa422b040a0aacdda079395624dd4f5548ed7af637b1594012aac75b309cef260b41c10a623410f815fc089b54ca5d80955d5f2ead12841b1
DIST lz4-2.1.6.tar.gz 129066 BLAKE2B 1a739c54946150441ddd4025b4ce8bf79a718d64a714ca5cfeaf8712c73fa88c47e1823a08ec7ad50acd31cba5bc10292f4c9e0905d8b5965b789944dd6eca9f SHA512 e37f9576f182adab263d8248e846c9f7d8a0260b2d2c5f94d74ebf3c2e51d91ba07d4bb0bf8a7560981a930fd380a2a3f5c4d21f4de5be3ae066d44a2246e9b5
+DIST lz4-3.0.2.tar.gz 152443 BLAKE2B 3bf452b5b5ee65caed13b21fd7c39f32ccdea18e6d900facf74e3271868299a2da258b2b0058efaea12a3b42006f0ad0d17004692c95be951c173fee1a1162be SHA512 c31116ee3cd70241b19bff6c59d1852d4c26ad5f0c9a56cd2ecec58e8c2751773162c7ac6a2d887e8cf537bc869ed8866929164f976849efa3ea041eacc4535a
diff --git a/dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch b/dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch
new file mode 100644
index 000000000000..40e6be63ff01
--- /dev/null
+++ b/dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch
@@ -0,0 +1,19 @@
+--- a/tests/stream/test_stream_1.py 2020-04-29 13:00:05.213776356 -0700
++++ b/tests/stream/test_stream_1.py 2020-04-29 13:16:33.958779776 -0700
+@@ -172,6 +172,8 @@
+
+
+ def test_invalid_config_d_4(store_comp_size):
++
++ pytest.skip('Known test failure, bug: https://github.com/python-lz4/python-lz4/issues/199')
+ d_kwargs = {}
+ d_kwargs['strategy'] = "double_buffer"
+ d_kwargs['buffer_size'] = 1 << (8 * store_comp_size['store_comp_size'])
+@@ -231,6 +233,8 @@
+
+
+ def test_invalid_config_d_5():
++
++ pytest.skip('Known test failure, bug: https://github.com/python-lz4/python-lz4/issues/199')
+ d_kwargs = {}
+ d_kwargs['strategy'] = "double_buffer"
diff --git a/dev-python/lz4/lz4-3.0.2.ebuild b/dev-python/lz4/lz4-3.0.2.ebuild
new file mode 100644
index 000000000000..f46bebe41b22
--- /dev/null
+++ b/dev-python/lz4/lz4-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/lz4"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# known test failure: https://github.com/python-lz4/python-lz4/issues/199
+PATCHES=( "${FILESDIR}/lz4-3.0.2-test-fail-skip.patch"
+)
+
+distutils_enable_tests pytest