summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-13 19:10:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-13 19:55:56 +0200
commit993e16f2b0586bea00417927b3ad2562fd787029 (patch)
treeb41f359220c1219e122ac14de7481694e0be0f71 /dev-python/mamba
parentdev-python/elementpath: Bump to 2.0.3 (diff)
downloadgentoo-993e16f2b0586bea00417927b3ad2562fd787029.tar.gz
gentoo-993e16f2b0586bea00417927b3ad2562fd787029.tar.bz2
gentoo-993e16f2b0586bea00417927b3ad2562fd787029.zip
dev-python/mamba: bump to 0.11.1, support Python 3.9, add doc
* mamba's test dependencies depend on it for tests, they will get Python 3.9 support in the following commits. * mock is not needed for Python 3, see https://github.com/nestorsalceda/mamba/pull/153. * The call to python_optimize seems to be unnecessary. * Remove one unused dependency. Closes: https://bugs.gentoo.org/740768 Package-Manager: Portage-3.0.6, Repoman-3.0.1 RepoMan-Options: --force Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/mamba')
-rw-r--r--dev-python/mamba/Manifest1
-rw-r--r--dev-python/mamba/mamba-0.11.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/mamba/Manifest b/dev-python/mamba/Manifest
index 281c5e1affd1..f8ec2f544ed1 100644
--- a/dev-python/mamba/Manifest
+++ b/dev-python/mamba/Manifest
@@ -1 +1,2 @@
DIST mamba-0.11.0.tar.gz 33598 BLAKE2B c52ccbf1fca5dd6f27b4515fa6db65a8a28537e705d734bb126bdc9a4bd4afb5119aabc212f871508f91c21679e7e2215d0c7f13adfaabdf6ea49c942b7b3d64 SHA512 2faf941700800ba0432bfd170d6ff2278e5fc3ba4e85f486d33ed5f07e148284d400e2b02ac0f957a27d47b705fc52b042dc4311bdd175907e307e4dbfa95246
+DIST mamba-0.11.1.tar.gz 36974 BLAKE2B 0bffac92c32413be736c20f926094cd2003c8bd8abb47abda7c63a071af5b99729f32b5cdb74f21f30f0b50be81674f08f79dc37416e8c67e2ae03c9a837eda4 SHA512 2b28415e5352fcec8028a8ddef6ff83a0cf2ebbb385506eb97f6a46be619277136a61180e8cf30047efd7807f867a03a0d1032dbfed27e2fc050a8639f67814c
diff --git a/dev-python/mamba/mamba-0.11.1.ebuild b/dev-python/mamba/mamba-0.11.1.ebuild
new file mode 100644
index 000000000000..b29bf908938c
--- /dev/null
+++ b/dev-python/mamba/mamba-0.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python test runner born under the banner of Behavior Driven Development"
+HOMEPAGE="https://nestorsalceda.github.io/mamba"
+SRC_URI="https://github.com/nestorsalceda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/doublex-expects-0.7.0_rc1[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ "${EPYTHON}" -m mamba.cli || die "Tests failed under ${EPYTHON}"
+}