summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-19 23:15:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-19 23:17:46 +0100
commit6c3041696fed4119fbf1599535e08515c356a586 (patch)
tree756fcb5422f590df8c806367c2b04d287f51b4bf /dev-python/marshmallow
parentdev-python/dbusmock: Bump to 0.20.0 (diff)
downloadgentoo-6c3041696fed4119fbf1599535e08515c356a586.tar.gz
gentoo-6c3041696fed4119fbf1599535e08515c356a586.tar.bz2
gentoo-6c3041696fed4119fbf1599535e08515c356a586.zip
dev-python/marshmallow: Bump to 3.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.10.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 64a3f2c1aea2..e5b73814dc45 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
+DIST marshmallow-3.10.0.tar.gz 172801 BLAKE2B 1d1f5d531a9704a9b82170347e2c5dd2b3fd4488204a05f9be7705a39e5a6a42342bcce1438484c22944a6fb4470a731825314ed7ced79dbaf9cc195f049d9b2 SHA512 41520a7cfde483ca06a69e49ab04f8972932d0fbf7a6c75ef568779b55d5f2f666aead4c161e03416e9b90fba71fd73b3f14630f0d7050b8a7fe7a4bb50d5bf0
DIST marshmallow-3.5.1.tar.gz 168839 BLAKE2B 8abf8e8d45d37794c3c615f6dac8ccd0acb76357e92ddaa4c23232b7aefba63db9bd42fb7f13dd99f9ea2ec4c7608459bc36014f9344ab91894176d0f02259c9 SHA512 89b3abce9e31dad6a20cf8ceef62270c8f95cbdf80965b6d29f1728d37d51171a020463da9d0354688183ea07e3f47a0ddab8694da13fe238f11a3dc755d4d6e
diff --git a/dev-python/marshmallow/marshmallow-3.10.0.ebuild b/dev-python/marshmallow/marshmallow-3.10.0.ebuild
new file mode 100644
index 000000000000..7adf1de6ee1d
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest