summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-18 20:04:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-18 21:11:36 +0300
commit240451e0e40a831b5d814236b66360f6984826d5 (patch)
treece73394e78edcbea277491b5fdac5829e0de2085 /dev-python/matplotlib-inline
parentdev-python/boto3: add 1.24.54 (diff)
downloadgentoo-240451e0e40a831b5d814236b66360f6984826d5.tar.gz
gentoo-240451e0e40a831b5d814236b66360f6984826d5.tar.bz2
gentoo-240451e0e40a831b5d814236b66360f6984826d5.zip
dev-python/matplotlib-inline: add 0.1.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib-inline')
-rw-r--r--dev-python/matplotlib-inline/Manifest1
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/Manifest b/dev-python/matplotlib-inline/Manifest
index 09cb11b0ea01..f70f50f7a419 100644
--- a/dev-python/matplotlib-inline/Manifest
+++ b/dev-python/matplotlib-inline/Manifest
@@ -1,2 +1,3 @@
DIST matplotlib-inline-0.1.3.gh.tar.gz 7337 BLAKE2B 995b6e5ce9068760e701e3b429d2187bdc7e7c5b989d54a9fb1f8b5f385f91c6a3621a54d5a1e62c9000737f5f42d9ceae5be7f36b664b7e06ff9c712e6d76ac SHA512 684821204faa3cb35c46663b8c8cb8f0ba5d4f761d15bc708de69c98753685c89da1d330087bcfa970792de592188768dc068accc471d55360f551e44cf4a79a
DIST matplotlib-inline-0.1.5.gh.tar.gz 7520 BLAKE2B 90fe7ed66b6d0ef7fd2b2a9478847adaa37af281ea383b60a1d01091d1be338411ccb2480e4bf34f0722e29cf6564a58ab358718c7704ac0c1c09375ba043627 SHA512 2a12d675ae6db1657f7202450ef3d889618c896d3571fd1a6c43b75fba1d72e80e49a06d55f7c333381b1afd2cd4a9ef282b5bcbadd2b53a19e02bd3f8bc9301
+DIST matplotlib-inline-0.1.6.gh.tar.gz 7526 BLAKE2B fd8fde8e218e19fdf7a09bd7f36abd2e4422ed7de8ed8e2d6e52d995e76b62d8e60223fc43a243f2a0ca545037b44ead9520b67cf54b173d95389eb401b17e9a SHA512 7d34f5a86d65d7a2017cf924dc363d7578d1eb14943c3de56e5a0ac79d92d674b387c5528ea76e9e11e0193e71d8cd1315ceb517e9c9678c41ed412e8fd42c04
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild
new file mode 100644
index 000000000000..90cd627e843a
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"