summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 21:40:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:29:58 +0100
commitc858f990e7bf28ce49247f83ebd4e5d32b25e5ac (patch)
tree91b75e9cc6c6b451e866a51f6aa2bdf1bf39cbb7 /dev-python/matplotlib-inline
parentsys-libs/timezone-data: Stabilize 2021e hppa, #833659 (diff)
downloadgentoo-c858f990e7bf28ce49247f83ebd4e5d32b25e5ac.tar.gz
gentoo-c858f990e7bf28ce49247f83ebd4e5d32b25e5ac.tar.bz2
gentoo-c858f990e7bf28ce49247f83ebd4e5d32b25e5ac.zip
dev-python/matplotlib-inline: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib-inline')
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.3-r1.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..ddc247e6a9b8
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"