summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2018-05-28 08:22:01 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-29 10:00:26 +0200
commit9fc066ac05f1cc48898741309177e17ae0a243cf (patch)
tree5b77a343b78b9da23df6d090af458db81d81a119 /dev-python/matplotlib2tikz
parentdev-python/jupyter_client: Version bump to 5.2.3 (diff)
downloadgentoo-9fc066ac05f1cc48898741309177e17ae0a243cf.tar.gz
gentoo-9fc066ac05f1cc48898741309177e17ae0a243cf.tar.bz2
gentoo-9fc066ac05f1cc48898741309177e17ae0a243cf.zip
dev-python/matplotlib2tikz: Version bump to 0.6.17
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/8629
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index b7484d46c669..dfa67eb38205 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.6.15.tar.gz 526046 BLAKE2B 4cc3585fe1a83c563fd00928843a16b4ba1ab2fecf8b662beaf40cd9e0211fb4fdb09c4bc4c1f110452621cf5d92f86bb492d0838be20693b86c3b4e9bd73566 SHA512 1f5b05319090d74fbd7ec99ad0e3f236f44107de2381d69e423f5878ba4c7666caca46ab87ae187f52f3ffa907cc4d75018b2ce6c9bcef44062e369f9a26be11
+DIST matplotlib2tikz-0.6.17.tar.gz 526409 BLAKE2B 704ede0539aeb9668b4c1534b6dd13bb2a5bc18e7861bfdbe2e9002cc5a8b8c4639ac77384e1249c52ef33e04986b85f27dc5219e9c9c7c8b7b03cb5a7bf586c SHA512 9a8f34a69147271bb252a4e04bc5ce27c39fc976c29d1530df109287bbfd163f37a3b5f3d6a03def962e06c2a69e7d256028b12372847fbe14459cc664eca199
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild
new file mode 100644
index 000000000000..6aaaf8cd6d9e
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}