summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-07 14:06:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 14:09:47 +0200
commit0a402a7eb06f7d5d3311fcf7d98e67041f6e5072 (patch)
treef2d55a4b167854c20344ecec6097c90f24f199f0 /dev-python/matplotlib
parentapp-backup/duplicity: fix missing setuptools_scm dep (diff)
downloadgentoo-0a402a7eb06f7d5d3311fcf7d98e67041f6e5072.tar.gz
gentoo-0a402a7eb06f7d5d3311fcf7d98e67041f6e5072.tar.bz2
gentoo-0a402a7eb06f7d5d3311fcf7d98e67041f6e5072.zip
dev-python/matplotlib: Fix running tests in virtx
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.2.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.2.1.ebuild b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
index 73d88adfdbe7..4f734e5cc240 100644
--- a/dev-python/matplotlib/matplotlib-3.2.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
@@ -199,7 +199,6 @@ python_configure() {
wrap_setup() {
local MAKEOPTS=-j1
local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
- unset DISPLAY
"$@"
}
@@ -219,6 +218,10 @@ python_compile_all() {
fi
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
# we need to rebuild mpl against bundled freetype, otherwise
# over 1000 tests will fail because of mismatched font rendering