summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-14 00:11:31 +0000
committerSam James <sam@gentoo.org>2020-09-14 00:11:34 +0000
commit3eff68af64d2eb5051fd6c111aeab6544b404e7a (patch)
tree0ea0541dd95b1832e68394f3af7b5250f08247fe /dev-python/matplotlib
parentdev-vcs/topgit: fix test run failures (diff)
downloadgentoo-3eff68af64d2eb5051fd6c111aeab6544b404e7a.tar.gz
gentoo-3eff68af64d2eb5051fd6c111aeab6544b404e7a.tar.bz2
gentoo-3eff68af64d2eb5051fd6c111aeab6544b404e7a.zip
dev-python/matplotlib: depend on pillow[jpeg]
This can cause test failures if missing. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.2.2-r2.ebuild (renamed from dev-python/matplotlib/matplotlib-3.2.2-r1.ebuild)2
-rw-r--r--dev-python/matplotlib/matplotlib-3.3.0-r1.ebuild (renamed from dev-python/matplotlib/matplotlib-3.3.0.ebuild)2
-rw-r--r--dev-python/matplotlib/matplotlib-3.3.1-r2.ebuild (renamed from dev-python/matplotlib/matplotlib-3.3.1-r1.ebuild)2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.2.2-r1.ebuild b/dev-python/matplotlib/matplotlib-3.2.2-r2.ebuild
index a653f14fcd90..3296b24075d0 100644
--- a/dev-python/matplotlib/matplotlib-3.2.2-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.2.2-r2.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
>=dev-python/cycler-0.10.0-r1[${PYTHON_USEDEP}]
>=dev-python/kiwisolver-1.2.0[${PYTHON_USEDEP}]
>=dev-python/numpy-1.18.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-7.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-7.1.1[jpeg,${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-3.3.0.ebuild b/dev-python/matplotlib/matplotlib-3.3.0-r1.ebuild
index 9b46b5e7164c..92a63fef1567 100644
--- a/dev-python/matplotlib/matplotlib-3.3.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.3.0-r1.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
>=dev-python/cycler-0.10.0-r1[${PYTHON_USEDEP}]
>=dev-python/kiwisolver-1.2.0[${PYTHON_USEDEP}]
>=dev-python/numpy-1.18.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-7.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-7.1.1[jpeg,${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-3.3.1-r1.ebuild b/dev-python/matplotlib/matplotlib-3.3.1-r2.ebuild
index 981026cbe93b..d8b120fa06ff 100644
--- a/dev-python/matplotlib/matplotlib-3.3.1-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.3.1-r2.ebuild
@@ -33,7 +33,7 @@ RDEPEND="
>=dev-python/cycler-0.10.0-r1[${PYTHON_USEDEP}]
>=dev-python/kiwisolver-1.2.0[${PYTHON_USEDEP}]
>=dev-python/numpy-1.18.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-7.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-7.1.1[jpeg,${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]