summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-18 09:30:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-18 12:26:03 +0200
commita956b9ef5a5c759521ed18f0db829d86876ced35 (patch)
tree52fd17b958b767a1848175571f800f3c053beaf8 /dev-python/matplotlib
parentdev-python/chameleon: Bump to 3.7.4 (diff)
downloadgentoo-a956b9ef5a5c759521ed18f0db829d86876ced35.tar.gz
gentoo-a956b9ef5a5c759521ed18f0db829d86876ced35.tar.bz2
gentoo-a956b9ef5a5c759521ed18f0db829d86876ced35.zip
dev-python/matplotlib: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest1
-rw-r--r--dev-python/matplotlib/files/matplotlib-3.2.2-test.patch419
-rw-r--r--dev-python/matplotlib/matplotlib-3.2.2.ebuild271
3 files changed, 691 insertions, 0 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 084a32c6e211..76cf20e63bd7 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -3,3 +3,4 @@ DIST matplotlib-2.2.2.tar.gz 37317332 BLAKE2B 4120265263c5b1e4ab57f7c0eb7a477b40
DIST matplotlib-2.2.4.tar.gz 36974286 BLAKE2B 9c4c69163a23ff02107ee155f72e142dcf31ba965f6a20f468b96f3f4b70b95ff6caade6b14bcbacd5b231848d2000ce6af9f113feefb41d6e186725349490d3 SHA512 968f5731b8a9a2c5575403c60d5b0a98a452b33094e520be44f4d901f892d082babc8fc1d73c519e1ff2baf756f3cb7652f4b796e166d66dfda31f7e50c58139
DIST matplotlib-3.1.2.tar.gz 40909582 BLAKE2B 670907670335ca13ec01f3acf036fd502ce34abd12666b2e0d10867c6115a0fe80039326cee89099471aa6b3bbd25f1ca4aa837072dea624ee41984da9f647be SHA512 2eff3c0525d01824ed758a87f50a3f6094767b580fca1eae4e9dbc2cc972af3d0cc3ac9615e576c5685e8bfc1ec90754bc826635f4f2a919d0b26bbb686cccab
DIST matplotlib-3.2.1.tar.gz 40325615 BLAKE2B 7fd299f7d3948987e341e4313ed82d15de286a05c9819893e099ccd6c1f861ce5548ec85588a382603011e7710d08d6fc9a4f168f0b5705b0873b97e40d2dd39 SHA512 d6497a3c47eaff9c0d981bc03de5894a3f4a5413cbe320924b1df6d68eb421e548cf4247c035fd636a4403cd2d50071633e6906e795b74ec7d9c4816193e42be
+DIST matplotlib-3.2.2.tar.gz 40295831 BLAKE2B 32fb34b95d1df928f949fd7b04909da2494b56efbe543f75bffedf1d9d85a0089a50cd27b82a28ac75361b56fe3f2a6c95b7d9e777778ce46f1d2805e5dae9df SHA512 4b8080fddc717f311a87b6ef1a279304da2931ef2d6de85688c153f14da5009351f42d9533c44695ca43ce1496bb642927aca822a7946a2d50d40a7d25224b31
diff --git a/dev-python/matplotlib/files/matplotlib-3.2.2-test.patch b/dev-python/matplotlib/files/matplotlib-3.2.2-test.patch
new file mode 100644
index 000000000000..13755eaa33e2
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-3.2.2-test.patch
@@ -0,0 +1,419 @@
+From 7a65dfda781777872083623595c27dc1174b2ed7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 7 Jun 2020 20:02:48 +0200
+Subject: [PATCH 1/2] Increase image comparison limits
+
+Most of the tests require exact match which apparently doesn't always
+happen in non-pristine environments. Some of them have very big
+differences due to texlive font rendering changes.
+---
+ lib/matplotlib/tests/test_arrow_patches.py | 4 ++--
+ lib/matplotlib/tests/test_axes.py | 2 +-
+ lib/matplotlib/tests/test_backend_pgf.py | 7 ++++---
+ lib/matplotlib/tests/test_figure.py | 2 +-
+ lib/matplotlib/tests/test_legend.py | 6 +++---
+ lib/matplotlib/tests/test_pickle.py | 2 +-
+ lib/matplotlib/tests/test_units.py | 4 ++--
+ lib/matplotlib/tests/test_usetex.py | 3 ++-
+ lib/mpl_toolkits/tests/test_axes_grid1.py | 2 +-
+ .../tests/test_axisartist_grid_helper_curvelinear.py | 2 +-
+ 10 files changed, 18 insertions(+), 16 deletions(-)
+
+diff --git a/lib/matplotlib/tests/test_arrow_patches.py b/lib/matplotlib/tests/test_arrow_patches.py
+index a9409e2c1..0e356e921 100644
+--- a/lib/matplotlib/tests/test_arrow_patches.py
++++ b/lib/matplotlib/tests/test_arrow_patches.py
+@@ -67,7 +67,7 @@ def __prepare_fancyarrow_dpi_cor_test():
+
+
+ @image_comparison(['fancyarrow_dpi_cor_100dpi.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0),
++ tol={'aarch64': 0.02}.get(platform.machine(), 0.015),
+ savefig_kwarg=dict(dpi=100))
+ def test_fancyarrow_dpi_cor_100dpi():
+ """
+@@ -82,7 +82,7 @@ def test_fancyarrow_dpi_cor_100dpi():
+
+
+ @image_comparison(['fancyarrow_dpi_cor_200dpi.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0),
++ tol={'aarch64': 0.02}.get(platform.machine(), 0.018),
+ savefig_kwarg=dict(dpi=200))
+ def test_fancyarrow_dpi_cor_200dpi():
+ """
+diff --git a/lib/matplotlib/tests/test_axes.py b/lib/matplotlib/tests/test_axes.py
+index 75636301d..af057d598 100644
+--- a/lib/matplotlib/tests/test_axes.py
++++ b/lib/matplotlib/tests/test_axes.py
+@@ -3673,7 +3673,7 @@ def test_vertex_markers():
+
+
+ @image_comparison(['vline_hline_zorder', 'errorbar_zorder'],
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol={'aarch64': 0.02}.get(platform.machine(), 0.015))
+ def test_eb_line_zorder():
+ x = list(range(10))
+
+diff --git a/lib/matplotlib/tests/test_backend_pgf.py b/lib/matplotlib/tests/test_backend_pgf.py
+index 7843b4101..ddb2991c1 100644
+--- a/lib/matplotlib/tests/test_backend_pgf.py
++++ b/lib/matplotlib/tests/test_backend_pgf.py
+@@ -97,7 +97,8 @@ def test_xelatex():
+ # test compiling a figure to pdf with pdflatex
+ @needs_pdflatex
+ @pytest.mark.backend('pgf')
+-@image_comparison(['pgf_pdflatex.pdf'], style='default')
++@image_comparison(['pgf_pdflatex.pdf'], style='default',
++ tol=11.669)
+ def test_pdflatex():
+ if os.environ.get('APPVEYOR', False):
+ pytest.xfail("pdflatex test does not work on appveyor due to missing "
+@@ -133,7 +134,7 @@ def test_rcupdate():
+ 'pgf.preamble': ['\\usepackage[utf8x]{inputenc}',
+ '\\usepackage[T1]{fontenc}',
+ '\\usepackage{sfmath}']}]
+- tol = [6, 0]
++ tol = [6, 14]
+ for i, rc_set in enumerate(rc_sets):
+ with mpl.rc_context(rc_set):
+ create_figure()
+@@ -161,7 +162,7 @@ def test_pathclip():
+ @needs_xelatex
+ @pytest.mark.backend('pgf')
+ @image_comparison(['pgf_mixedmode.pdf'], style='default',
+- tol={'aarch64': 1.086}.get(platform.machine(), 0.0))
++ tol=1.086)
+ def test_mixedmode():
+ rc_xelatex = {'font.family': 'serif',
+ 'pgf.rcfonts': False}
+diff --git a/lib/matplotlib/tests/test_figure.py b/lib/matplotlib/tests/test_figure.py
+index b5ca0ed5b..885afa5f8 100644
+--- a/lib/matplotlib/tests/test_figure.py
++++ b/lib/matplotlib/tests/test_figure.py
+@@ -14,7 +14,7 @@ import pytest
+
+
+ @image_comparison(['figure_align_labels'],
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol=0.02)
+ def test_align_labels():
+ # Check the figure.align_labels() command
+ fig = plt.figure(tight_layout=True)
+diff --git a/lib/matplotlib/tests/test_legend.py b/lib/matplotlib/tests/test_legend.py
+index 71499da44..a8bda6e84 100644
+--- a/lib/matplotlib/tests/test_legend.py
++++ b/lib/matplotlib/tests/test_legend.py
+@@ -106,7 +106,7 @@ def test_multiple_keys():
+
+
+ @image_comparison(['rgba_alpha.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol=0.02)
+ def test_alpha_rgba():
+ import matplotlib.pyplot as plt
+
+@@ -117,7 +117,7 @@ def test_alpha_rgba():
+
+
+ @image_comparison(['rcparam_alpha.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol=0.02)
+ def test_alpha_rcparam():
+ import matplotlib.pyplot as plt
+
+@@ -145,7 +145,7 @@ def test_fancy():
+
+
+ @image_comparison(['framealpha'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol=0.02)
+ def test_framealpha():
+ x = np.linspace(1, 100, 100)
+ y = x
+diff --git a/lib/matplotlib/tests/test_pickle.py b/lib/matplotlib/tests/test_pickle.py
+index 0fad3cdf2..4d2599607 100644
+--- a/lib/matplotlib/tests/test_pickle.py
++++ b/lib/matplotlib/tests/test_pickle.py
+@@ -41,7 +41,7 @@ def test_simple():
+
+
+ @image_comparison(['multi_pickle.png'], remove_text=True, style='mpl20',
+- tol={'aarch64': 0.082}.get(platform.machine(), 0.0))
++ tol=0.082)
+ def test_complete():
+ fig = plt.figure('Figure with a label?', figsize=(10, 6))
+
+diff --git a/lib/matplotlib/tests/test_units.py b/lib/matplotlib/tests/test_units.py
+index f14425144..7f744da47 100644
+--- a/lib/matplotlib/tests/test_units.py
++++ b/lib/matplotlib/tests/test_units.py
+@@ -74,7 +74,7 @@ def quantity_converter():
+ # Tests that the conversion machinery works properly for classes that
+ # work as a facade over numpy arrays (like pint)
+ @image_comparison(['plot_pint.png'], remove_text=False, style='mpl20',
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol={'aarch64': 0.02}.get(platform.machine(), 0.002))
+ def test_numpy_facade(quantity_converter):
+ # use former defaults to match existing baseline image
+ plt.rcParams['axes.formatter.limits'] = -7, 7
+@@ -101,7 +101,7 @@ def test_numpy_facade(quantity_converter):
+
+ # Tests gh-8908
+ @image_comparison(['plot_masked_units.png'], remove_text=True, style='mpl20',
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol=0.02)
+ def test_plot_masked_units():
+ data = np.linspace(-5, 5)
+ data_masked = np.ma.array(data, mask=(data > -2) & (data < 2))
+diff --git a/lib/matplotlib/tests/test_usetex.py b/lib/matplotlib/tests/test_usetex.py
+index ec693288e..8af6b69eb 100644
+--- a/lib/matplotlib/tests/test_usetex.py
++++ b/lib/matplotlib/tests/test_usetex.py
+@@ -15,7 +15,8 @@ if not mpl.checkdep_usetex(True):
+ @image_comparison(
+ baseline_images=['test_usetex'],
+ extensions=['pdf', 'png'],
+- style="mpl20")
++ style="mpl20",
++ tol=21)
+ def test_usetex():
+ mpl.rcParams['text.usetex'] = True
+ fig = plt.figure()
+diff --git a/lib/mpl_toolkits/tests/test_axes_grid1.py b/lib/mpl_toolkits/tests/test_axes_grid1.py
+index 9ed9a9280..56a3bd14a 100644
+--- a/lib/mpl_toolkits/tests/test_axes_grid1.py
++++ b/lib/mpl_toolkits/tests/test_axes_grid1.py
+@@ -343,7 +343,7 @@ def test_zooming_with_inverted_axes():
+
+
+ @image_comparison(['anchored_direction_arrows.png'],
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ tol=0.02)
+ def test_anchored_direction_arrows():
+ fig, ax = plt.subplots()
+ ax.imshow(np.zeros((10, 10)), interpolation='nearest')
+diff --git a/lib/mpl_toolkits/tests/test_axisartist_grid_helper_curvelinear.py b/lib/mpl_toolkits/tests/test_axisartist_grid_helper_curvelinear.py
+index 611908063..dc294aef5 100644
+--- a/lib/mpl_toolkits/tests/test_axisartist_grid_helper_curvelinear.py
++++ b/lib/mpl_toolkits/tests/test_axisartist_grid_helper_curvelinear.py
+@@ -17,7 +17,7 @@ from mpl_toolkits.axisartist.grid_helper_curvelinear import \
+
+
+ @image_comparison(['custom_transform.png'], style='default',
+- tol={'aarch64': 0.034}.get(platform.machine(), 0.03))
++ tol=0.034)
+ def test_custom_transform():
+ class MyTransform(Transform):
+ input_dims = 2
+--
+2.27.0
+
+From 506611e80a4fd12b3f633583d20119fc2f096ba7 Mon Sep 17 00:00:00 2001
+From: Antony Lee <anntzer.lee@gmail.com>
+Date: Tue, 10 Dec 2019 11:18:24 +0100
+Subject: [PATCH 2/2] Rewrite test_cycles to avoid image comparison tests.
+
+They can all be reasonably written by checking the artist properties.
+---
+ lib/matplotlib/tests/test_cycles.py | 141 ++++++++++------------------
+ 1 file changed, 51 insertions(+), 90 deletions(-)
+
+diff --git a/lib/matplotlib/tests/test_cycles.py b/lib/matplotlib/tests/test_cycles.py
+index ee67b4e41..a340b6166 100644
+--- a/lib/matplotlib/tests/test_cycles.py
++++ b/lib/matplotlib/tests/test_cycles.py
+@@ -1,6 +1,4 @@
+-import platform
+-
+-from matplotlib.testing.decorators import image_comparison
++import matplotlib as mpl
+ import matplotlib.pyplot as plt
+ import numpy as np
+ import pytest
+@@ -8,133 +6,96 @@ import pytest
+ from cycler import cycler
+
+
+-@image_comparison(['color_cycle_basic.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
+ def test_colorcycle_basic():
+ fig, ax = plt.subplots()
+ ax.set_prop_cycle(cycler('color', ['r', 'g', 'y']))
+- xs = np.arange(10)
+- ys = 0.25 * xs + 2
+- ax.plot(xs, ys, label='red', lw=4)
+- ys = 0.45 * xs + 3
+- ax.plot(xs, ys, label='green', lw=4)
+- ys = 0.65 * xs + 4
+- ax.plot(xs, ys, label='yellow', lw=4)
+- ys = 0.85 * xs + 5
+- ax.plot(xs, ys, label='red2', lw=4)
+- ax.legend(loc='upper left')
+-
+-
+-@image_comparison(['marker_cycle.png', 'marker_cycle.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ for _ in range(4):
++ ax.plot(range(10), range(10))
++ assert [l.get_color() for l in ax.lines] == ['r', 'g', 'y', 'r']
++
++
+ def test_marker_cycle():
+ fig, ax = plt.subplots()
+ ax.set_prop_cycle(cycler('c', ['r', 'g', 'y']) +
+ cycler('marker', ['.', '*', 'x']))
+- xs = np.arange(10)
+- ys = 0.25 * xs + 2
+- ax.plot(xs, ys, label='red dot', lw=4, ms=16)
+- ys = 0.45 * xs + 3
+- ax.plot(xs, ys, label='green star', lw=4, ms=16)
+- ys = 0.65 * xs + 4
+- ax.plot(xs, ys, label='yellow x', lw=4, ms=16)
+- ys = 0.85 * xs + 5
+- ax.plot(xs, ys, label='red2 dot', lw=4, ms=16)
+- ax.legend(loc='upper left')
++ for _ in range(4):
++ ax.plot(range(10), range(10))
++ assert [l.get_color() for l in ax.lines] == ['r', 'g', 'y', 'r']
++ assert [l.get_marker() for l in ax.lines] == ['.', '*', 'x', '.']
+
++
++def test_marker_cycle_kwargs_arrays_iterators():
+ fig, ax = plt.subplots()
+- # Test keyword arguments, numpy arrays, and generic iterators
+ ax.set_prop_cycle(c=np.array(['r', 'g', 'y']),
+ marker=iter(['.', '*', 'x']))
+- xs = np.arange(10)
+- ys = 0.25 * xs + 2
+- ax.plot(xs, ys, label='red dot', lw=4, ms=16)
+- ys = 0.45 * xs + 3
+- ax.plot(xs, ys, label='green star', lw=4, ms=16)
+- ys = 0.65 * xs + 4
+- ax.plot(xs, ys, label='yellow x', lw=4, ms=16)
+- ys = 0.85 * xs + 5
+- ax.plot(xs, ys, label='red2 dot', lw=4, ms=16)
+- ax.legend(loc='upper left')
+-
+-
+-@image_comparison(['lineprop_cycle_basic.png'], remove_text=True,
+- tol={'aarch64': 0.02}.get(platform.machine(), 0.0))
++ for _ in range(4):
++ ax.plot(range(10), range(10))
++ assert [l.get_color() for l in ax.lines] == ['r', 'g', 'y', 'r']
++ assert [l.get_marker() for l in ax.lines] == ['.', '*', 'x', '.']
++
++
+ def test_linestylecycle_basic():
+ fig, ax = plt.subplots()
+ ax.set_prop_cycle(cycler('ls', ['-', '--', ':']))
+- xs = np.arange(10)
+- ys = 0.25 * xs + 2
+- ax.plot(xs, ys, label='solid', lw=4, color='k')
+- ys = 0.45 * xs + 3
+- ax.plot(xs, ys, label='dashed', lw=4, color='k')
+- ys = 0.65 * xs + 4
+- ax.plot(xs, ys, label='dotted', lw=4, color='k')
+- ys = 0.85 * xs + 5
+- ax.plot(xs, ys, label='solid2', lw=4, color='k')
+- ax.legend(loc='upper left')
+-
+-
+-@image_comparison(['fill_cycle_basic.png'], remove_text=True)
++ for _ in range(4):
++ ax.plot(range(10), range(10))
++ assert [l.get_linestyle() for l in ax.lines] == ['-', '--', ':', '-']
++
++
+ def test_fillcycle_basic():
+ fig, ax = plt.subplots()
+ ax.set_prop_cycle(cycler('c', ['r', 'g', 'y']) +
+ cycler('hatch', ['xx', 'O', '|-']) +
+ cycler('linestyle', ['-', '--', ':']))
+- xs = np.arange(10)
+- ys = 0.25 * xs**.5 + 2
+- ax.fill(xs, ys, label='red, xx', linewidth=3)
+- ys = 0.45 * xs**.5 + 3
+- ax.fill(xs, ys, label='green, circle', linewidth=3)
+- ys = 0.65 * xs**.5 + 4
+- ax.fill(xs, ys, label='yellow, cross', linewidth=3)
+- ys = 0.85 * xs**.5 + 5
+- ax.fill(xs, ys, label='red2, xx', linewidth=3)
+- ax.legend(loc='upper left')
+-
+-
+-@image_comparison(['fill_cycle_ignore.png'], remove_text=True)
++ for _ in range(4):
++ ax.fill(range(10), range(10))
++ assert ([p.get_facecolor() for p in ax.patches]
++ == [mpl.colors.to_rgba(c) for c in ['r', 'g', 'y', 'r']])
++ assert [p.get_hatch() for p in ax.patches] == ['xx', 'O', '|-', 'xx']
++ assert [p.get_linestyle() for p in ax.patches] == ['-', '--', ':', '-']
++
++
+ def test_fillcycle_ignore():
+ fig, ax = plt.subplots()
+ ax.set_prop_cycle(cycler('color', ['r', 'g', 'y']) +
+ cycler('hatch', ['xx', 'O', '|-']) +
+ cycler('marker', ['.', '*', 'D']))
+- xs = np.arange(10)
+- ys = 0.25 * xs**.5 + 2
++ t = range(10)
+ # Should not advance the cycler, even though there is an
+ # unspecified property in the cycler "marker".
+ # "marker" is not a Polygon property, and should be ignored.
+- ax.fill(xs, ys, 'r', hatch='xx', label='red, xx')
+- ys = 0.45 * xs**.5 + 3
++ ax.fill(t, t, 'r', hatch='xx')
+ # Allow the cycler to advance, but specify some properties
+- ax.fill(xs, ys, hatch='O', label='red, circle')
+- ys = 0.65 * xs**.5 + 4
+- ax.fill(xs, ys, label='green, circle')
+- ys = 0.85 * xs**.5 + 5
+- ax.fill(xs, ys, label='yellow, cross')
+- ax.legend(loc='upper left')
++ ax.fill(t, t, hatch='O')
++ ax.fill(t, t)
++ ax.fill(t, t)
++ assert ([p.get_facecolor() for p in ax.patches]
++ == [mpl.colors.to_rgba(c) for c in ['r', 'r', 'g', 'y']])
++ assert [p.get_hatch() for p in ax.patches] == ['xx', 'O', 'O', '|-']
+
+
+-@image_comparison(['property_collision_plot.png'], remove_text=True)
+ def test_property_collision_plot():
+ fig, ax = plt.subplots()
+ ax.set_prop_cycle('linewidth', [2, 4])
++ t = range(10)
+ for c in range(1, 4):
+- ax.plot(np.arange(10), c * np.arange(10), lw=0.1, color='k')
+- ax.plot(np.arange(10), 4 * np.arange(10), color='k')
+- ax.plot(np.arange(10), 5 * np.arange(10), color='k')
++ ax.plot(t, t, lw=0.1)
++ ax.plot(t, t)
++ ax.plot(t, t)
++ assert [l.get_linewidth() for l in ax.lines] == [0.1, 0.1, 0.1, 2, 4]
+
+
+-@image_comparison(['property_collision_fill.png'], remove_text=True)
+ def test_property_collision_fill():
+ fig, ax = plt.subplots()
+- xs = np.arange(10)
+- ys = 0.25 * xs**.5 + 2
+ ax.set_prop_cycle(linewidth=[2, 3, 4, 5, 6], facecolor='bgcmy')
++ t = range(10)
+ for c in range(1, 4):
+- ax.fill(xs, c * ys, lw=0.1)
+- ax.fill(xs, 4 * ys)
+- ax.fill(xs, 5 * ys)
++ ax.fill(t, t, lw=0.1)
++ ax.fill(t, t)
++ ax.fill(t, t)
++ assert ([p.get_facecolor() for p in ax.patches]
++ == [mpl.colors.to_rgba(c) for c in 'bgcmy'])
++ assert [p.get_linewidth() for p in ax.patches] == [0.1, 0.1, 0.1, 5, 6]
+
+
+ def test_valid_input_forms():
+--
+2.27.0
+
diff --git a/dev-python/matplotlib/matplotlib-3.2.2.ebuild b/dev-python/matplotlib/matplotlib-3.2.2.ebuild
new file mode 100644
index 000000000000..59b723084553
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-3.2.2.ebuild
@@ -0,0 +1,271 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+
+FT_PV=2.6.1
+DESCRIPTION="Pure python plotting library with matlab like syntax"
+HOMEPAGE="https://matplotlib.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? (
+ https://downloads.sourceforge.net/project/freetype/freetype2/${FT_PV}/freetype-${FT_PV}.tar.gz
+ )"
+
+# Main license: matplotlib
+# Some modules: BSD
+# matplotlib/backends/qt4_editor: MIT
+# Fonts: BitstreamVera, OFL-1.1
+LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="cairo doc excel examples gtk3 latex qt5 tk wxwidgets"
+
+# internal copy of pycxx highly patched
+# dev-python/pycxx
+RDEPEND="
+ >=dev-python/cycler-0.10.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/kiwisolver-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.18.2[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14.0[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ media-fonts/stix-fonts
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=media-libs/qhull-2013
+ >=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
+ cairo? (
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ )
+ excel? (
+ dev-python/xlwt[${PYTHON_USEDEP}]
+ )
+ gtk3? (
+ dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ )
+ latex? (
+ virtual/latex-base
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ app-text/poppler[utils]
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ wxwidgets? (
+ $(python_gen_cond_dep '
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ ' python3_{6,7,8})
+ )
+"
+
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-text/dvipng-1.15-r1
+ >=dev-python/colorspacious-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-7.1.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython-1.18.2[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.9.2[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-gallery-0.3.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/xlwt-1.3.0-r1[${PYTHON_USEDEP}]
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexrecommended
+ >=media-gfx/graphviz-2.42.3[cairo]
+ )
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ )
+"
+
+# A few C++ source files are written to srcdir.
+# Other than that, the ebuild shall be fit for out-of-source build.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ unset DISPLAY # bug #278524
+}
+
+use_supported() {
+ case ${1} in
+ wxwidgets)
+ [[ ${EPYTHON} == python3.[678] ]]
+ ;;
+ esac
+
+ return 0
+}
+
+use_setup() {
+ local uword="${2:-${1}}"
+ if use_supported "${1}" && use "${1}"; then
+ echo "${uword} = True"
+ echo "${uword}agg = True"
+ else
+ echo "${uword} = False"
+ echo "${uword}agg = False"
+ fi
+}
+
+python_prepare_all() {
+# Generates test failures, but fedora does it
+# local PATCHES=(
+# "${FILESDIR}"/${P}-unbundle-pycxx.patch
+# "${FILESDIR}"/${P}-unbundle-agg.patch
+# )
+# rm -r agg24 CXX || die
+# rm -r agg24 || die
+
+# cat > lib/${PN}/externals/six.py <<-EOF
+# from __future__ import absolute_import
+# from six import *
+# EOF
+
+ local PATCHES=(
+ "${FILESDIR}"/matplotlib-3.1.2-qhull.patch
+ "${FILESDIR}"/matplotlib-3.2.2-test.patch
+ )
+
+ # requires jupyter-nbconvert
+ rm lib/matplotlib/tests/test_backend_nbagg.py || die
+
+ sed \
+ -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
+ -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
+ || die "sed pyparsing failed"
+
+ sed -e 's:\(@pytest.mark.flaky\)(reruns=3):\1:' \
+ -i lib/matplotlib/tests/test_*.py || die
+
+ hprefixify setupext.py
+
+ rm -rf libqhull || die
+
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+ append-cppflags -DNDEBUG # or get old trying to do triangulation
+ tc-export PKG_CONFIG
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+
+ # create setup.cfg (see setup.cfg.template for any changes).
+
+ # common switches.
+ cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
+ [directories]
+ basedirlist = ${EPREFIX}/usr
+ [provide_packages]
+ pytz = False
+ dateutil = False
+ [packages]
+ tests = $(usex test True False)
+ [gui_support]
+ agg = True
+ gtk = False
+ gtkagg = False
+ pyside = False
+ pysideagg = False
+ qt4 = False
+ qt4agg = False
+ $(use_setup cairo)
+ $(use_setup gtk3)
+ $(use_setup qt5)
+ $(use_setup tk)
+ $(use_setup wxwidgets wx)
+ EOF
+
+ if use gtk3 && use cairo; then
+ echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
+ else
+ echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
+ fi
+}
+
+wrap_setup() {
+ local MAKEOPTS=-j1
+ local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
+ "$@"
+}
+
+python_compile() {
+ wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
+}
+
+python_compile_all() {
+ if use doc; then
+ cd doc || die
+
+ # necessary for in-source build
+ local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
+
+ VARTEXFONTS="${T}"/fonts \
+ emake SPHINXOPTS= O=-Dplot_formats=png:100 html
+ fi
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # we need to rebuild mpl against bundled freetype, otherwise
+ # over 1000 tests will fail because of mismatched font rendering
+ local -x MPLLOCALFREETYPE=1
+ ln -s "${WORKDIR}/freetype-${FT_PV}" "${BUILD_DIR}" || die
+ wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/test-lib
+ local -x PYTHONPATH=${BUILD_DIR}/test-lib:${PYTHONPATH}
+
+ "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(m.test(verbosity=2))" || die
+}
+
+python_install() {
+ wrap_setup distutils-r1_python_install
+
+ # mpl_toolkits namespace
+ python_moduleinto mpl_toolkits
+ python_domodule lib/mpl_toolkits/__init__.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ find "${D}" -name '*.pth' -delete || die
+}