summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-07 09:52:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 09:52:36 +0200
commitbb9e707ad097ea4f24ffa3008bd452c8d5c38d07 (patch)
treef2db5db3a9702b672b987e191eb3915543ba875a /dev-python/matplotlib
parentdev-ruby/fakefs: add 1.2.2 (diff)
downloadgentoo-bb9e707ad097ea4f24ffa3008bd452c8d5c38d07.tar.gz
gentoo-bb9e707ad097ea4f24ffa3008bd452c8d5c38d07.tar.bz2
gentoo-bb9e707ad097ea4f24ffa3008bd452c8d5c38d07.zip
dev-python/matplotlib: Fix returning test failures
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.2.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.2.1.ebuild b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
index 50d6eee36e36..ac48950448ac 100644
--- a/dev-python/matplotlib/matplotlib-3.2.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
@@ -216,7 +216,7 @@ python_test() {
wrap_setup distutils_install_for_testing
distutils_install_for_testing
- "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || die
+ "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(m.test(verbosity=2))" || die
}
python_install() {