summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 08:46:49 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 08:46:49 +0100
commite76eb6f17968c523b546fc42d2f50e6e4102ca53 (patch)
tree7a542254e2bdd0fb64a668e0a721ad38a90b1d25 /dev-python/matplotlib
parentdev-python/pyinotify: Add python3.5 support (diff)
downloadgentoo-e76eb6f17968c523b546fc42d2f50e6e4102ca53.tar.gz
gentoo-e76eb6f17968c523b546fc42d2f50e6e4102ca53.tar.bz2
gentoo-e76eb6f17968c523b546fc42d2f50e6e4102ca53.zip
dev-python/matplotlib: Backport patch for problems with sphinx-1.3.4
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.5.1-sphinx-1.4.3-backport.patch58
-rw-r--r--dev-python/matplotlib/matplotlib-1.5.1.ebuild2
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/matplotlib/files/matplotlib-1.5.1-sphinx-1.4.3-backport.patch b/dev-python/matplotlib/files/matplotlib-1.5.1-sphinx-1.4.3-backport.patch
new file mode 100644
index 000000000000..19c111d87962
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-1.5.1-sphinx-1.4.3-backport.patch
@@ -0,0 +1,58 @@
+From b7dfa4fa7a69d091dac0ead295d28422c4e33b45 Mon Sep 17 00:00:00 2001
+From: Thomas A Caswell <tcaswell@gmail.com>
+Date: Sun, 24 Jan 2016 13:05:18 -0500
+Subject: [PATCH] Merge pull request #5872 from jenshnielsen/sphinx134
+
+DOC: Fix issue with Sphinx 1.3.4
+
+Discarded changes to .travis.yml from #5872
+---
+ lib/matplotlib/dviread.py | 2 +-
+ lib/matplotlib/patches.py | 18 ++++++++++++------
+ 2 files changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/lib/matplotlib/dviread.py b/lib/matplotlib/dviread.py
+index db6e976..1141f6a 100644
+--- a/lib/matplotlib/dviread.py
++++ b/lib/matplotlib/dviread.py
+@@ -841,7 +841,7 @@ def find_tex_file(filename, format=None):
+ """
+ Call :program:`kpsewhich` to find a file in the texmf tree. If
+ *format* is not None, it is used as the value for the
+- :option:`--format` option.
++ `--format` option.
+
+ Apparently most existing TeX distributions on Unix-like systems
+ use kpathsea. I hear MikTeX (a popular distribution on Windows)
+diff --git a/lib/matplotlib/patches.py b/lib/matplotlib/patches.py
+index b8b7363..917eca7 100644
+--- a/lib/matplotlib/patches.py
++++ b/lib/matplotlib/patches.py
+@@ -2992,15 +2992,21 @@ class Bar(_Base):
+
+ def __init__(self, armA=0., armB=0., fraction=0.3, angle=None):
+ """
+- *armA* : minimum length of armA
++ Parameters
++ ----------
++ armA : float
++ minimum length of armA
+
+- *armB* : minimum length of armB
++ armB : float
++ minimum length of armB
+
+- *fraction* : a fraction of the distance between two points that
+- will be added to armA and armB.
++ fraction : float
++ a fraction of the distance between two points that
++ will be added to armA and armB.
+
+- *angle* : angle of the connecting line (if None, parallel to A
+- and B)
++ angle : float or None
++ angle of the connecting line (if None, parallel
++ to A and B)
+ """
+ self.armA = armA
+ self.armB = armB
diff --git a/dev-python/matplotlib/matplotlib-1.5.1.ebuild b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
index 904233abff9a..3635965d3f89 100644
--- a/dev-python/matplotlib/matplotlib-1.5.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
@@ -74,7 +74,6 @@ DEPEND="${COMMON_DEPEND}
dev-python/mock[${PY2_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.3.4
dev-python/xlwt[${PYTHON_USEDEP}]
dev-texlive/texlive-latexextra
dev-texlive/texlive-fontsrecommended
@@ -112,6 +111,7 @@ RDEPEND="${COMMON_DEPEND}
DISTUTILS_IN_SOURCE_BUILD=1
PATCHES=(
+ "${FILESDIR}"/${P}-sphinx-1.4.3-backport.patch
"${FILESDIR}"/${P}-test-fix-backport.patch
"${FILESDIR}"/${P}-test-fix-backport-2.patch
)