summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-12-11 02:42:41 +0100
committerMichał Górny <mgorny@gentoo.org>2016-12-11 16:39:49 +0100
commitfbc0a1cc52b08173f049388291da8d42b8bb5fc2 (patch)
tree3031efca55db8adac2d0b3fb8961ae5c8e3545ce /dev-python/meld3/meld3-1.0.2-r1.ebuild
parentapp-misc/neofetch: version bump to 2.0.2 (diff)
downloadgentoo-fbc0a1cc52b08173f049388291da8d42b8bb5fc2.tar.gz
gentoo-fbc0a1cc52b08173f049388291da8d42b8bb5fc2.tar.bz2
gentoo-fbc0a1cc52b08173f049388291da8d42b8bb5fc2.zip
dev-python/meld3: add py3.5, EAPI=6, fix license, deps and tests
Closes: https://github.com/gentoo/gentoo/pull/3074 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/meld3/meld3-1.0.2-r1.ebuild')
-rw-r--r--dev-python/meld3/meld3-1.0.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/meld3/meld3-1.0.2-r1.ebuild b/dev-python/meld3/meld3-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..8975dde39249
--- /dev/null
+++ b/dev-python/meld3/meld3-1.0.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine"
+HOMEPAGE="https://github.com/supervisor/meld3 https://pypi.python.org/pypi/meld3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}