summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-10-11 17:52:25 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-10-11 17:52:25 -0700
commit5a04c1d161f3eb0ac629ac3eeba93b32a7089f66 (patch)
treea948581e6d64a84487a52d986c33a4cedaaa6a53 /dev-python/memory_profiler
parentnet-misc/openssh: Add updated X509 patchset to 7.6_p1 (diff)
downloadgentoo-5a04c1d161f3eb0ac629ac3eeba93b32a7089f66.tar.gz
gentoo-5a04c1d161f3eb0ac629ac3eeba93b32a7089f66.tar.bz2
gentoo-5a04c1d161f3eb0ac629ac3eeba93b32a7089f66.zip
dev-python/memory_profiler: Version bump to 0.47
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest1
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.47.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index 868fcaaab904..87651c9b3fbe 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1 +1,2 @@
DIST memory_profiler-0.43.tar.gz 31496 SHA256 ee2d4fb8f95b90d6faa511e46f4d117d4f17f7c62bb081f7266e9c98c23aeba4 SHA512 6c0bbece0b2a7da5504e878db3777ae86009ed3730a00527af457e4c216e7f5423feee79216bf28496374a2a597fd0cc2b267a312587ed01ac42f6ec3351eca6 WHIRLPOOL e0ac0eb1a99463fe295277768c4c97f23e7bd70f34e9d8a32b115247baa4c51b3c639e86ae24e77602aa97a648d026b36afd1c35dfda63bd7e7759bf5aeddcea
+DIST memory_profiler-0.47.tar.gz 33725 SHA256 e992f2a341a5332dad1ad4a008eeac7cfe78c7ea4abdf7535a3e7e79093328cb SHA512 110e16ecad33068d31cf53b2f0b775d65230d51345f24a4d7d3cafafb706b10a0c7e2d98a799256b0366f1bafa9b69c060222595bb4eb9e1689301428a36fc3d WHIRLPOOL d2c9352868aaaca8505826dfc537258b79727dfe7366403aff4d769ee1790d2e779a46f8e11b1e06b42196e70b72d33850a4972a4896b39713c0fa61d000479e
diff --git a/dev-python/memory_profiler/memory_profiler-0.47.ebuild b/dev-python/memory_profiler/memory_profiler-0.47.ebuild
new file mode 100644
index 000000000000..3c9eee9a0e51
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.47.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="http://pypi.python.org/pypi/memory_profiler https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ if python_is_python3; then
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+ fi
+ ${PYTHON} test/test_tracemalloc.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}