summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-08 19:20:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-08 19:20:16 +0100
commit6b42667c233366f6741a97977b37c579ec357671 (patch)
tree244c5b27bfd27ac1939ee22ad9c4af278abf199f /dev-python/memory_profiler
parentdev-python/mkdocs-material: Remove old (diff)
downloadgentoo-6b42667c233366f6741a97977b37c579ec357671.tar.gz
gentoo-6b42667c233366f6741a97977b37c579ec357671.tar.bz2
gentoo-6b42667c233366f6741a97977b37c579ec357671.zip
dev-python/memory_profiler: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest1
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.58.0.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index daa6aeffaf9c..d7315859fdb9 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,3 +1,2 @@
-DIST memory_profiler-0.58.0.gh.tar.gz 140692 BLAKE2B 2f3917d833dfcc722b61871c7e704e869527a389b10a81b473989b8455630f5defa5f5b21a172708070b89468c7dd66682cd3b9c0bf435e9be49651b69b50137 SHA512 5c02933acffc05f42d2ae98a069d36563e1d26515d439d94ad3903960dd06cd378faae3000b26c022770e71e83db6f770ceaf63cabb92f4159bda0ff9cc4e849
DIST memory_profiler-0.59.gh.tar.gz 142586 BLAKE2B b9c8cffbd03f980937d30626facf431e6effd9a86a21fbe629f4238a2f78f2d65242637105ad3a07b4158a6335a541701bba657941bb23c9da0f49a1113402ee SHA512 f70ad8f871bd5068e2817049231abee7e535cb352f0444dcb0d9d072b9f4dda944e85ec7854855307a9748257da80f53dd50fe17fefbd73045dce1306f51f88d
DIST memory_profiler-0.60.gh.tar.gz 142585 BLAKE2B aa7fd9e547eecadc184d4da5830c582a9a9ab9565f3dc9c763caaa7e75698ed6b499d2555e4a93b39d2f80f85fad025b84043e0812cb25dd1511f4ebf8da5a85 SHA512 407e44a410cdb4c7c8cc5ff40198c28012f8b0c6bba88d2d1612681eb621a1b802ef137be62fc64ca9e3c362ca3814433bc12169d7c3827bf97293c5bbb8bfbc
diff --git a/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
deleted file mode 100644
index fb5f53ccb4a9..000000000000
--- a/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A module for monitoring memory usage of a python program"
-HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/pythonprofilers/memory_profiler"
-SRC_URI="
- https://github.com/pythonprofilers/memory_profiler/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-IUSE="examples"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-# dev-lang/mercury: collision on 'mprof'
-# https://bugs.gentoo.org/571176
-RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
- !dev-lang/mercury"
-
-distutils_enable_tests pytest
-
-python_test() {
- ${EPYTHON} -m memory_profiler test/test_as.py || die
- ${EPYTHON} -m memory_profiler test/test_func.py || die
- ${EPYTHON} -m memory_profiler test/test_gen.py || die
- ${EPYTHON} -m memory_profiler test/test_loop.py || die
- ${EPYTHON} -m memory_profiler test/test_loop_decorated.py || die
- ${EPYTHON} -m memory_profiler test/test_mprofile.py || die
- ${EPYTHON} -m memory_profiler test/test_nested.py || die
- ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
- ${EPYTHON} -m memory_profiler test/test_unicode.py || die
-
- ${EPYTHON} test/test_exception.py || die
- ${EPYTHON} test/test_exit_code.py || die
- ${EPYTHON} test/test_global.py || die
- ${EPYTHON} test/test_import.py || die
- ${EPYTHON} test/test_memory_usage.py || die
- ${EPYTHON} test/test_mprof.py || die
- ${EPYTHON} test/test_precision_import.py || die
- ${EPYTHON} test/test_stream_unicode.py || die
- ${EPYTHON} test/test_tracemalloc.py || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}