summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-18 11:58:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-18 12:00:04 +0100
commit8f629c13e48dae9909baf601ad224d9adf8276ea (patch)
tree2873ddee36a4bde38d28a1b1e558b5fa4f06dffd /dev-python/meteor-ejson
parentdev-python/pyee: initial import; ebuild by me (diff)
downloadgentoo-8f629c13e48dae9909baf601ad224d9adf8276ea.tar.gz
gentoo-8f629c13e48dae9909baf601ad224d9adf8276ea.tar.bz2
gentoo-8f629c13e48dae9909baf601ad224d9adf8276ea.zip
dev-python/meteor-ejson: initial import; ebuild by me
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/meteor-ejson')
-rw-r--r--dev-python/meteor-ejson/Manifest1
-rw-r--r--dev-python/meteor-ejson/metadata.xml13
-rw-r--r--dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/meteor-ejson/Manifest b/dev-python/meteor-ejson/Manifest
new file mode 100644
index 000000000000..5c3619a49575
--- /dev/null
+++ b/dev-python/meteor-ejson/Manifest
@@ -0,0 +1 @@
+DIST meteor-ejson-1.1.0.tar.gz 2292 SHA256 17c10d00ae4ed4ab8daf3b1e18f1bbe46803058cb6ff81d9d5a73ae6b565224a SHA512 eb211d262f0006f3229296b71320f68b59d8a7e618e65baa8e613f874a0e6ac9cfe45e30fc73ba57c42129204c5f27a32c4b8b579527fcefd601fa1dc2844da3 WHIRLPOOL 7338c6587ed7f43383fb53ee0d63020a545138e51fd47b4eaaa44ac4ceb771628cad0480060a1cee4833e06814a0e2acefd88bf5fe28f288d7ab32eca5ea2017
diff --git a/dev-python/meteor-ejson/metadata.xml b/dev-python/meteor-ejson/metadata.xml
new file mode 100644
index 000000000000..cdc8aea2111d
--- /dev/null
+++ b/dev-python/meteor-ejson/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">meteor-ejson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild b/dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild
new file mode 100644
index 000000000000..fbe66fb87862
--- /dev/null
+++ b/dev-python/meteor-ejson/meteor-ejson-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP"
+HOMEPAGE="https://pypi.python.org/pypi/meteor-ejson https://github.com/lyschoening/meteor-ejson-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die
+}