summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-25 19:02:52 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-25 19:42:50 -0800
commitae3cb2d827f364d606cf48064f062208cc0d2f09 (patch)
tree360610a0a53e759cb93a7525d0f0d0898c394b74 /dev-python/mistune
parentapp-emulation/buildah: Remove old versions (diff)
downloadgentoo-ae3cb2d827f364d606cf48064f062208cc0d2f09.tar.gz
gentoo-ae3cb2d827f364d606cf48064f062208cc0d2f09.tar.bz2
gentoo-ae3cb2d827f364d606cf48064f062208cc0d2f09.zip
dev-python/mistune-0.8.4: Bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/mistune')
-rw-r--r--dev-python/mistune/Manifest1
-rw-r--r--dev-python/mistune/mistune-0.8.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
index 8bfe4fe11ec7..924bdd56a5b3 100644
--- a/dev-python/mistune/Manifest
+++ b/dev-python/mistune/Manifest
@@ -1 +1,2 @@
DIST mistune-0.8.3.tar.gz 58506 BLAKE2B a4b96162514ba1b82710c9264d9005f151943d525ff7e28a2fd4a92b16d4c90818715bf851573e25be203537a3059dbec1e86c75ec0ebd0a4b164303c06d7029 SHA512 fc0b6d53e7a62712b752bff77c2529750628e9e1eeec02603bd2c793f9b0a46efe31fe7a749c5d6aae3c591d74e43c45e450179650bfb57128fb0ec366de6aa3
+DIST mistune-0.8.4.tar.gz 58322 BLAKE2B e65d45c5c95706a49a7fd407afe5f10e82a475766ca272ec3bebba8c89e670fe6efced7b09537efb69d3fd36e75091e370170a15ad7488b5cbe9186e2ccaf4db SHA512 36c3ef5d5537f5cceaa43e4da20a84b27c378cb744a93f0380024faefde490bcb42c453f79002ca049083fc437278f4afb3e10de5462f9eeb9077ca2a2fcaea7
diff --git a/dev-python/mistune/mistune-0.8.4.ebuild b/dev-python/mistune/mistune-0.8.4.ebuild
new file mode 100644
index 000000000000..32ed617d423f
--- /dev/null
+++ b/dev-python/mistune/mistune-0.8.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose