summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-03 19:31:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-03 20:27:32 +0300
commitcbf1f1a89b9b8d3b73dd717c6763d88968d567c1 (patch)
treea0b4abf6c7e584e3485e2cf981406b51f7c48d20 /dev-python/mkautodoc
parentdev-python/frozenlist: add 1.3.1 (diff)
downloadgentoo-cbf1f1a89b9b8d3b73dd717c6763d88968d567c1.tar.gz
gentoo-cbf1f1a89b9b8d3b73dd717c6763d88968d567c1.tar.bz2
gentoo-cbf1f1a89b9b8d3b73dd717c6763d88968d567c1.zip
dev-python/mkautodoc: add 0.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mkautodoc')
-rw-r--r--dev-python/mkautodoc/Manifest1
-rw-r--r--dev-python/mkautodoc/mkautodoc-0.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/mkautodoc/Manifest b/dev-python/mkautodoc/Manifest
index 7467e3b3f01f..f84f4c0fbcc0 100644
--- a/dev-python/mkautodoc/Manifest
+++ b/dev-python/mkautodoc/Manifest
@@ -1 +1,2 @@
DIST mkautodoc-0.1.0.tar.gz 5654 BLAKE2B c0ae754e800ea25e9cccc621b4fd5c8d1561c57808b301ac5a3036ca18fda1adc432006e13b777a83dcc2cd6960a34745e17dfbcbbda24098902198d4fc9d743 SHA512 7ccb0a03016e2984d88d78eca2a8ee01e2153ff574c912358640c158b2084e3c365ace0fdb89cb74bb1950c68775d9d3cb11201cbf3c6d136dc7886a3294dc89
+DIST mkautodoc-0.2.0.gh.tar.gz 6914 BLAKE2B dc00da8415933775dba4d3dd1e2082b74c1c32da5953e68e1cf01727c6ba0471b83b9c45641975945a914a2403159f96c347a48f0fd743bdf446da2ee3f9e801 SHA512 d0151294fb530c0bf1f10fbf026426487acc68c5b2da0067847ade86a4327a0c826a0f51e7cc0f519594a3a38a1a1d3d304bd5be47bdfc1979b6fa20eb57187f
diff --git a/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild b/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild
new file mode 100644
index 000000000000..f5e837d4c962
--- /dev/null
+++ b/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Auto documentation for MkDocs"
+HOMEPAGE="
+ https://github.com/tomchristie/mkautodoc/
+ https://pypi.org/project/mkautodoc/
+"
+SRC_URI="https://github.com/tomchristie/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}"
+ distutils-r1_src_test
+}