summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:29:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit842e7408eb53beb91730ee90fc3f67291494eaf0 (patch)
treea892e90e9317a8604e3f1c52a3ee77fb345ef990 /dev-python/mock
parentdev-python/mimeparse: Add python3.5 support (diff)
downloadgentoo-842e7408eb53beb91730ee90fc3f67291494eaf0.tar.gz
gentoo-842e7408eb53beb91730ee90fc3f67291494eaf0.tar.bz2
gentoo-842e7408eb53beb91730ee90fc3f67291494eaf0.zip
dev-python/mock: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/mock')
-rw-r--r--dev-python/mock/mock-1.3.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mock/mock-1.3.0-r2.ebuild b/dev-python/mock/mock-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..ddcdc19b6a6c
--- /dev/null
+++ b/dev-python/mock/mock-1.3.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rolling backport of unittest.mock for all Pythons"
+HOMEPAGE="https://github.com/testing-cabal/mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc test"
+
+CDEPEND="$(python_gen_cond_dep 'dev-python/funcsigs[${PYTHON_USEDEP}]' 'python2_7')
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/unittest2-1.1.0[${PYTHON_USEDEP}]' python{2_7,3_3} pypy)
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.7[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests || die "tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local DOCS=( docs/*.txt )
+
+ distutils-r1_python_install_all
+}