summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-03 23:36:29 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-03 23:37:17 +0100
commit784086ddf2ab56186e473be8b3d7ae667f5234df (patch)
tree06f75cc6e1a93d0773f7fbd8a9f96b3816c2b6d8 /dev-python/mpdlcd
parentx11-misc/xflux-gui: add 2.0 (diff)
downloadgentoo-784086ddf2ab56186e473be8b3d7ae667f5234df.tar.gz
gentoo-784086ddf2ab56186e473be8b3d7ae667f5234df.tar.bz2
gentoo-784086ddf2ab56186e473be8b3d7ae667f5234df.zip
dev-python/mpdlcd: migrate to pep517
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/mpdlcd')
-rw-r--r--dev-python/mpdlcd/Manifest2
-rw-r--r--dev-python/mpdlcd/mpdlcd-0.5.2-r2.ebuild (renamed from dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild)10
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/mpdlcd/Manifest b/dev-python/mpdlcd/Manifest
index 48aaf4c73f1b..0792edb63c23 100644
--- a/dev-python/mpdlcd/Manifest
+++ b/dev-python/mpdlcd/Manifest
@@ -1 +1 @@
-DIST mpdlcd-0.5.2.tar.gz 30748 BLAKE2B 5609ac149a9aa806e516202adf1b9d0f4fc88e8370f331edc836082d7b3b85c519097149dd2b5cb838d8a9ff353421e17daf9236397e4b37e2923948f8dc9dac SHA512 e000120eee1ce99b549c5ac0cd00fba394ce1a373cce3dde819f6aabd6fc3b616e59ade6d6868b1e9f14afea4897cf541f2c3f5d0eaebcbbd03b15781a63b6fc
+DIST mpdlcd-0.5.2.gh.tar.gz 30748 BLAKE2B 5609ac149a9aa806e516202adf1b9d0f4fc88e8370f331edc836082d7b3b85c519097149dd2b5cb838d8a9ff353421e17daf9236397e4b37e2923948f8dc9dac SHA512 e000120eee1ce99b549c5ac0cd00fba394ce1a373cce3dde819f6aabd6fc3b616e59ade6d6868b1e9f14afea4897cf541f2c3f5d0eaebcbbd03b15781a63b6fc
diff --git a/dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild b/dev-python/mpdlcd/mpdlcd-0.5.2-r2.ebuild
index d1208674c66f..ec74bf095e7c 100644
--- a/dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild
+++ b/dev-python/mpdlcd/mpdlcd-0.5.2-r2.ebuild
@@ -3,13 +3,14 @@
EAPI=8
+DISTUTILS_USE_PEP517="setuptools"
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A small tool to display the MPD status on a LCDproc server"
HOMEPAGE="https://github.com/rbarrois/mpdlcd"
-SRC_URI="https://github.com/rbarrois/${PN}/archive/${P}.tar.gz"
+SRC_URI="https://github.com/rbarrois/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}/${PN}-${P}"
LICENSE="BSD"
@@ -20,6 +21,13 @@ RDEPEND="dev-python/python-mpd"
distutils_enable_tests pytest
+src_prepare() {
+ default
+
+ # Fix QA 'The license_file parameter is deprecated, use license_files instead.'
+ sed -e 's/license_file/license_files/g' -i setup.cfg || die
+}
+
python_install_all() {
distutils-r1_python_install_all