summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-07 13:55:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-07 13:57:56 +0200
commit0ecec5e1b2dc78da4c339e599c68f1863566e14c (patch)
tree5e2bbe5d8f29b23920fc9589fe360caf5f92cecc /dev-python/mpi4py/mpi4py-2.0.0.ebuild
parentnet-libs/telepathy-accounts-signon: Drop 1.0 (diff)
downloadgentoo-0ecec5e1b2dc78da4c339e599c68f1863566e14c.tar.gz
gentoo-0ecec5e1b2dc78da4c339e599c68f1863566e14c.tar.bz2
gentoo-0ecec5e1b2dc78da4c339e599c68f1863566e14c.zip
dev-python/mpi4py: Drop 2.0.0, 3.0.0
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/mpi4py/mpi4py-2.0.0.ebuild')
-rw-r--r--dev-python/mpi4py/mpi4py-2.0.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/mpi4py/mpi4py-2.0.0.ebuild b/dev-python/mpi4py/mpi4py-2.0.0.ebuild
deleted file mode 100644
index 3564ebdbd9b9..000000000000
--- a/dev-python/mpi4py/mpi4py-2.0.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.org/project/mpi4py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="virtual/mpi"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- virtual/mpi[romio] )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # not needed on install
- rm -vr docs/source || die
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- export FAKEROOTKEY=1
- distutils-r1_src_compile
-}
-
-python_test() {
- echo "Beginning test phase"
- pushd "${BUILD_DIR}"/../ &> /dev/null || die
- mpiexec -n 2 "${PYTHON}" ./test/runtests.py -v || die "Testsuite failed under ${EPYTHON}"
- popd &> /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- use examples && local DOCS=( demo )
- distutils-r1_python_install_all
-}