summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 09:24:25 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commitac03d93d9d718183d97fa852827c519dacf84990 (patch)
treec4941d706ec7e20206ba4545f8c93c9080eec0a9 /dev-python/msgpack
parentdev-python/mox3: Add python3.5 support (diff)
downloadgentoo-ac03d93d9d718183d97fa852827c519dacf84990.tar.gz
gentoo-ac03d93d9d718183d97fa852827c519dacf84990.tar.bz2
gentoo-ac03d93d9d718183d97fa852827c519dacf84990.zip
dev-python/msgpack: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/msgpack-0.4.6.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/msgpack/msgpack-0.4.6.ebuild b/dev-python/msgpack/msgpack-0.4.6.ebuild
index f1369e1aa4d7..aa06f99bec2f 100644
--- a/dev-python/msgpack/msgpack-0.4.6.ebuild
+++ b/dev-python/msgpack/msgpack-0.4.6.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
inherit distutils-r1
@@ -11,7 +12,10 @@ MY_PN="${PN}-python"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="http://msgpack.org https://github.com/msgpack/msgpack-python/ https://pypi.python.org/pypi/msgpack-python/"
+HOMEPAGE="
+ http://msgpack.org
+ https://github.com/msgpack/msgpack-python/
+ https://pypi.python.org/pypi/msgpack-python/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
@@ -19,7 +23,8 @@ SLOT="0"
KEYWORDS="amd64 arm x86"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/six[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]