summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-06-18 13:52:24 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-06-18 13:52:24 -0500
commit6f8f8bedb1d7741bc25eead00f4139637b69c81d (patch)
tree385ad7f24faff0269b510132c2070bdeba898665 /dev-python/multidict
parentdev-python/boto3: remove version 1.2.1 (diff)
downloadgentoo-6f8f8bedb1d7741bc25eead00f4139637b69c81d.tar.gz
gentoo-6f8f8bedb1d7741bc25eead00f4139637b69c81d.tar.bz2
gentoo-6f8f8bedb1d7741bc25eead00f4139637b69c81d.zip
dev-python/multidict: add version 1.1.0_beta4
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/multidict')
-rw-r--r--dev-python/multidict/Manifest1
-rw-r--r--dev-python/multidict/multidict-1.1.0_beta4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index c2d9fe4daa70..5532801c2435 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1,2 +1,3 @@
DIST multidict-1.1.0_alpha6.tar.gz 98630 SHA256 ac3f1a134c87a7f6e7547cbcb595e5eb36d1c1865101a777f2e7c0a18d824173 SHA512 fc221ca768cfc3c04c83e624296e5c0452d4d14a7a13ba8e8cb153ffd1ea7b7e949c628bc45d8c249b790cca1698fc0a5a6f2b57b113bcf9c055a972d2f15a7e WHIRLPOOL 7f8e057d41eb90246c84ba13165e6975ea5f985b5f65ae887efd2d4493ac0bd0980d9a56426a74b5f979a93a9007c2ef60ebbcf6966cedd8592ca3f1c379bb8e
DIST multidict-1.1.0_beta2.tar.gz 98311 SHA256 6a2b983764dbe08a5a06f6e29c490067a76b13a322cef22833cab3d29ed631f9 SHA512 b01fa6767bafd47f77681eef1807c1f24d831e776f7b5edc084bff8c2c181915df52ecc77c6def56004d0aa94167de80eb61dc02c8a3b825484ab71285bcdfd3 WHIRLPOOL bfb78bdf12be93dd5a40a1f41320bd10f6d1f4e9167b97d4d7332a9638a6738242445b6aa3bd0d621c5c36951ffb6f19a019bb1a12bc1b79673f67fe6d7b17fa
+DIST multidict-1.1.0_beta4.tar.gz 98339 SHA256 527e9714c7dcf59291a04dfd65ab031a1061649bea8a321f6830af64863e2a77 SHA512 b271f0be4cdf164aff59903dbf89689c18475731e146da1bb340c2307f0ee8d1fcf330de97e2300efc50df14c233ec5b74542b3e600017df1990a8e136dc3ae3 WHIRLPOOL e826a033fa6f841715145800211ba8768da551027da1130cc088b07c68f765256b0001b5c5fd5b348e5f7f1845e21579abba62ddb1f1f7571220865f0ccef415
diff --git a/dev-python/multidict/multidict-1.1.0_beta4.ebuild b/dev-python/multidict/multidict-1.1.0_beta4.ebuild
new file mode 100644
index 000000000000..6004a97114ec
--- /dev/null
+++ b/dev-python/multidict/multidict-1.1.0_beta4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV="${PV//_beta/b}"
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m pytest tests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}