summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-22 07:59:27 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-22 09:30:05 +0100
commit6e5cb4902716af0b9146f85d36f5e3f10875bfb4 (patch)
tree16242df429cfca0bf45f6e7353aab7eedddc1487 /dev-python/mypy
parentdev-python/pydantic-core: Bump to 2.14.6 (diff)
downloadgentoo-6e5cb4902716af0b9146f85d36f5e3f10875bfb4.tar.gz
gentoo-6e5cb4902716af0b9146f85d36f5e3f10875bfb4.tar.bz2
gentoo-6e5cb4902716af0b9146f85d36f5e3f10875bfb4.zip
dev-python/mypy: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-1.8.0.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 0fb7efb7cd54..faeb4240ff7b 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,2 +1,3 @@
DIST mypy-1.7.0.gh.tar.gz 3001996 BLAKE2B af29475dc4a24d75700144b8b2643de65d88d50d561ba6bdb0d64941dc19a2943829ee93f25ece679d213833bf7a68814c5aa83ec13eac3f22074356b1c47e1c SHA512 e8ba6b0897327e8a0718a0c46ed16ce81bf677e3084ca00ea0762215d79a2b52fe84329121cff257b575d13288621b98c550b9915bd1afcfa3c13d43a2087b23
DIST mypy-1.7.1.gh.tar.gz 3004203 BLAKE2B 5a61899e2deb9fd7dfd8634bfa269f19497fec6d601337d404a5106369650c5da0d6989acf5c4ed584d12b1d0e763e684a6650800cd2fc00f99f9a336f86e703 SHA512 07c047a4733c5d44b9e32cc5afa0b7dfa5719b3128cf52f68e5492a9680b09319bb1722a2080a4f93bd191c6504667985467a6ac0e7bef5389c38290879581c5
+DIST mypy-1.8.0.gh.tar.gz 3023408 BLAKE2B 81f987423f2bbef8f7f1b894983b34d34b0df408bae28fbb2cb59c5d4597b4d6b9afb8e9a2914aad969dcb621f1fe4ba4850b242bb76c4cfa35aae340f4f36b4 SHA512 231237ea44ccf619ac3d3f7f3cb42658bc9802d7a34f61101a9ac79f0fa67d8f566950e14dae3465c9620cdf67dc80cb65a3e2a6724ff944bfa911754caf592b
diff --git a/dev-python/mypy/mypy-1.8.0.ebuild b/dev-python/mypy/mypy-1.8.0.ebuild
new file mode 100644
index 000000000000..7bbb2610993d
--- /dev/null
+++ b/dev-python/mypy/mypy-1.8.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ native-extensions? (
+ ${RDEPEND}
+ dev-python/types-psutil[${PYTHON_USEDEP}]
+ dev-python/types-setuptools[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# frustratingly, mypyc produces non-deterministic output. If ccache is enabled it will be a waste of time,
+# but simultaneously it might trash your system and fill up the cache with a giant wave of non-reproducible
+# test files (https://github.com/mypyc/mypyc/issues/1014)
+export CCACHE_DISABLE=1
+
+src_compile() {
+ local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ # known broken with assertions enabled
+ # https://github.com/python/mypy/issues/16043
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64GlueMethodsAndInheritance
+ mypyc/test/test_run.py::TestRun::run-floats.test::testFloatOps
+ # these assume that types-docutils are not installed
+ mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testIgnoreImportIfNoPython3StubAvailable
+ mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testNoPython3StubAvailable
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # more assertions, sigh
+ mypyc/test/test_run.py::TestRun::run-bools.test::testBoolOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64BasicOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64DefaultArgValues
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64ErrorValuesAndUndefined
+ )
+ fi
+
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+
+ # The tests depend on having in-source compiled extensions if you want to
+ # test those compiled extensions. Various crucial test dependencies aren't
+ # installed. Even pyproject.toml is needed because that's where pytest args
+ # are in. Hack them into the build directory and delete them afterwards.
+ # See: https://github.com/python/mypy/issues/16143
+ local -x MYPY_TEST_PREFIX="${S}"
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ cp -r "${S}"/{conftest.py,pyproject.toml} . || die
+
+ local failed=
+ nonfatal epytest -n "$(makeopts_jobs)" --dist=worksteal || failed=1
+
+ rm conftest.py pyproject.toml || die
+
+ [[ ${failed} ]] && die "epytest failed with ${EPYTHON}"
+}