summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-11 10:14:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-11 11:36:32 +0100
commit7da0b3daec86f6c86b0fd1c668f2cb8e6d149d16 (patch)
tree951a883d7fe05f3658df41e6367c07fd282f3b60 /dev-python/mypy
parentdev-python/lit: Remove a flaky test (diff)
downloadgentoo-7da0b3daec86f6c86b0fd1c668f2cb8e6d149d16.tar.gz
gentoo-7da0b3daec86f6c86b0fd1c668f2cb8e6d149d16.tar.bz2
gentoo-7da0b3daec86f6c86b0fd1c668f2cb8e6d149d16.zip
dev-python/mypy: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-1.7.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 42c1c66461e9..5554f951f9a0 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,4 @@
DIST mypy-1.5.1.gh.tar.gz 2901212 BLAKE2B b136cf061162bc50a48f1556763d7a1258b5a29b63a77db9190f89c56d3e85375a2b0e826d75472a0dc37df4d3391f2d85bb5f1f29c2907055a978e3c8d75906 SHA512 2c81322c0e7d9621e6d189f4d9d25d77c5fd6decbb563c8d0015e0f94ff1ff8206e5b7a38884edd3eedb99e839c03283ebfa7d86577c9f8e0d707c0cc4eb8fed
DIST mypy-1.6.0.gh.tar.gz 2923757 BLAKE2B 15e0fe124b7024a3e89a8c32c13404f33bc56a3ff29375d006bfcaf9de359ea59025ba07e3726c7a4b402f4b7aca1256859585e1500891fb1e5f996b19dd499a SHA512 245324a5ec8a98e18c31159c5cb907ce1b60323428942b9fd60909a3b117ae46eeb97792fb1f30562fa411edb6c9e903f87b5b232a4be1242abe28d88406f7c4
DIST mypy-1.6.1.gh.tar.gz 2923973 BLAKE2B 1abaaab0c4ca4daa4914d69196312e371d030b6f81616da66102c5fcf6ad55ed2a6a9d56f9a55d2b6ebeb055b40947ab042e7b8744960185f5343dd9f05f9f4f SHA512 eac6b17dd418146c365a446e34c2cb403692a6ffa08b06a94c54accfbcedd441284c95894ef9f9b83e48df81edc35893b17163f6dba9f81fe7e9a8527401968b
+DIST mypy-1.7.0.gh.tar.gz 3001996 BLAKE2B af29475dc4a24d75700144b8b2643de65d88d50d561ba6bdb0d64941dc19a2943829ee93f25ece679d213833bf7a68814c5aa83ec13eac3f22074356b1c47e1c SHA512 e8ba6b0897327e8a0718a0c46ed16ce81bf677e3084ca00ea0762215d79a2b52fe84329121cff257b575d13288621b98c550b9915bd1afcfa3c13d43a2087b23
diff --git a/dev-python/mypy/mypy-1.7.0.ebuild b/dev-python/mypy/mypy-1.7.0.ebuild
new file mode 100644
index 000000000000..49d077bf8578
--- /dev/null
+++ b/dev-python/mypy/mypy-1.7.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/types-psutil[${PYTHON_USEDEP}]
+ dev-python/types-setuptools[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# frustratingly, mypyc produces non-deterministic output. If ccache is enabled it will be a waste of time,
+# but simultaneously it might trash your system and fill up the cache with a giant wave of non-reproducible
+# test files (https://github.com/mypyc/mypyc/issues/1014)
+export CCACHE_DISABLE=1
+
+src_compile() {
+ local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ # known broken with assertions enabled
+ # https://github.com/python/mypy/issues/16043
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64GlueMethodsAndInheritance
+ mypyc/test/test_run.py::TestRun::run-floats.test::testFloatOps
+ # these assume that types-docutils are not installed
+ mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testIgnoreImportIfNoPython3StubAvailable
+ mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testNoPython3StubAvailable
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # more assertions, sigh
+ mypyc/test/test_run.py::TestRun::run-bools.test::testBoolOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64BasicOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64DefaultArgValues
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64ErrorValuesAndUndefined
+ )
+ fi
+
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+
+ # The tests depend on having in-source compiled extensions if you want to
+ # test those compiled extensions. Various crucial test dependencies aren't
+ # installed. Even pyproject.toml is needed because that's where pytest args
+ # are in. Hack them into the build directory and delete them afterwards.
+ # See: https://github.com/python/mypy/issues/16143
+ local -x MYPY_TEST_PREFIX="${S}"
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ cp -r "${S}"/{conftest.py,pyproject.toml} . || die
+
+ local failed=
+ nonfatal epytest -n "$(makeopts_jobs)" --dist=worksteal || failed=1
+
+ rm conftest.py pyproject.toml || die
+
+ [[ ${failed} ]] && die "epytest failed with ${EPYTHON}"
+}